Bug 35380 - Wrong spell checking of double s and sharp s in german
Summary: Wrong spell checking of double s and sharp s in german
Status: CLOSED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-17 02:03 UTC by Bernhard Stickler
Modified: 2011-12-23 13:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Spell check "Masse" and "Maße", language attribute German (Germany) (33.38 KB, image/png)
2011-03-18 10:10 UTC, manj_k
Details
Example for spell checking behaviour (12.05 KB, application/vnd.oasis.opendocument.text)
2011-03-21 00:50 UTC, Bernhard Stickler
Details
Language setting in "Example for spell checking behaviour – spell_checking_test.odt" (97.07 KB, image/png)
2011-03-21 07:50 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Stickler 2011-03-17 02:03:41 UTC
In the german language are double "s" (ss) and sharp "s" (ß) completely different. The correct use is, that double s will be used after short spoken vowels und sharp "s" has to be used after long spoken vowels.
So there is a difference between "Masse" (=mass) and "Maße" (=measure).
LibreOffice underlines all words containing a sharp "s" an suggests a double "s". Thus many correct written words are underlined and will be wrong if the suggestion will be accepted.

BeSt wishes
Comment 1 manj_k 2011-03-18 10:08:33 UTC
I cannot confirm that issue [on WinXP] with:
- LibreOffice 3.3.1 OOO330m19 (Build:8) tag libreoffice-3.3.1.2
- Bundled (default) dictionary "German (DE-frami) spelling, hyphenation, thesaurus 2010.05.25"
- Language attribute "German (Germany)".

Maybe another dictionary or wrong language attribute "German (Switzerland)"?
Could you please attach a sample document?
Comment 2 manj_k 2011-03-18 10:10:11 UTC
Created attachment 44585 [details]
Spell check "Masse" and "Maße", language attribute German (Germany)
Comment 3 Bernhard Stickler 2011-03-21 00:49:47 UTC
(In reply to comment #2)
> Created an attachment (id=44585) [details]
> Spell check "Masse" and "Maße", language attribute German (Germany)

I use the language attribute German (Austria) but when I tried to reproduce the problem, I got a strange result.
In a new document with font style standard, the problem doesn't exist. But when I use footnote, the problem exists as described above.
I converted a big Word document and saved this document as odt. A big part of the document was converted to the font style footnote an so I couldn't recognize, that the spell checking depends on the font style. By the way, a very stange behaviour.

Please see the attachment with an example.
Comment 4 Bernhard Stickler 2011-03-21 00:50:42 UTC
Created attachment 44649 [details]
Example for spell checking behaviour
Comment 5 manj_k 2011-03-21 07:48:00 UTC
@Bernhard Stickler
About "spell_checking_test.odt" (comment 3)

The default setting of your document has the language attribute German (Austria),
also the paragraph style "Default", and most of the depending paragraph styles.

But the style "Footnote" is set to English (USA) and is direct (hard) formatted as German (Switzerland).
(See the status bar in the attached screenshot.)

The spell check works fine (as expected).
So I would propose to close Bug 35380 as INVALID.

(The described formatting issue may depend on your original Word document.)
Comment 6 manj_k 2011-03-21 07:50:17 UTC
Created attachment 44672 [details]
Language setting in "Example for spell checking behaviour – spell_checking_test.odt"
Comment 7 Bernhard Stickler 2011-03-21 08:08:03 UTC
Now I checked the original Word document and the footnote is also formatted in German (Switzerland) but there are no underlines.
So i changed the style in my odt document to German (Autria) now and it is ok.
I think there is still a problem in the document conversion, but i think i cannot describe it and close this issue.
Comment 8 Bernhard Stickler 2011-03-21 08:10:15 UTC
it seems to be little prob in document conversion.