Bug 35431 - Files exported to PDF with certain PDF/A-1a embedded fonts show dots in Adobe Reader
Summary: Files exported to PDF with certain PDF/A-1a embedded fonts show dots in Adobe...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: high major
Assignee: Luboš Luňák
URL: http://bugs.debian.org/cgi-bin/bugrep...
Whiteboard:
Keywords:
: 33703 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-18 11:43 UTC by Rune Tendal Kock
Modified: 2012-08-31 10:04 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
PDF from LibO that fails in Adobe Reader (36.57 KB, application/pdf)
2011-03-18 11:43 UTC, Rune Tendal Kock
Details
courier10pitch.odt (8.96 KB, application/vnd.oasis.opendocument.text)
2011-04-13 12:38 UTC, Christopher M. Penalver
Details
Resulting pdf from courier10pitch_334.pdf w/334 (48.69 KB, application/pdf)
2011-09-05 20:03 UTC, NoOp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rune Tendal Kock 2011-03-18 11:43:07 UTC
Created attachment 44590 [details]
PDF from LibO that fails in Adobe Reader

I use LibreOffice on Debian Testing AMD64 to generate a PDF (attached).

My document uses the font Bitstream Charter, which is part of the base Debian system.  I believe that it comes from X.Org, specifically the package xfonts-scalable.

Opening this PDF in Adobe Reader for Windows 9.4 or 10.0 produces an error message that the embedded font cannot be extracted, and all characters are replaced by dots.

The PDF works fine in the non-Adobe programs I've tried.

Choosing a different font avoids the problem.

It would be really great if LibreOffice can check for this problem, and maybe even apply a work-around.  Or at least show a warning when the PDF is generated.
Comment 1 Rene Engelhard 2011-03-18 11:50:50 UTC
FTR, we also had this reported in bugs.debian.org/616117
Comment 2 S. 2011-03-29 16:22:01 UTC
Confirmed on openSUSE 11.4 with both LibreOffice 3.3.1 and 3.3.2.
Comment 4 Tad Whiteside 2011-03-30 06:14:55 UTC
also a problem on i686 builds too
Comment 5 S. 2011-03-30 19:19:58 UTC
Same issue confirmed on openSUSE 11.4 32-bit with OpenOffice 3.3.0.
Comment 6 Christopher M. Penalver 2011-04-13 12:38:34 UTC
Created attachment 45587 [details]
courier10pitch.odt
Comment 7 Christopher M. Penalver 2011-04-13 12:39:38 UTC
Downstream bug may be found at:
https://bugs.launchpad.net/df-libreoffice/+bug/758676

1) lsb_release -rd
Description: Ubuntu Natty (development branch)
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu2
  Candidate: 1:3.3.2-1ubuntu2
  Version table:
 *** 1:3.3.2-1ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages 100
/var/lib/dpkg/status

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen is when one performs at the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/758676/+attachment/2030473/+files/courier10pitch.odt && lowriter -nologo courier10pitch.odt

Notice the words:

This line is Courier 10 Pitch.

has font Courier 10 Pitch.

Click File -> Export as PDF... -> check the PDF/A-1a checkbox -> Export button -> Name: courier10pitch -> click Save button

Open via the Terminal:

acroread courier10pitch.pdf

and it should display correctly.

4) What happens instead is an Adobe Reader window pops up noting: "Cannot extract the embedded font 'Courier10PitchBT-Roman'. Some characters may not display or print correctly."

In place of the words are dots.
Comment 8 Tad Whiteside 2011-05-03 19:42:02 UTC
I have back-traced this bug - it first appears in OpenOffice 3.3.0. 

It was not present in the Ubuntu packaged OpenOffice 3.2.0.

To test this I installed a virtual machine with Ubuntu 10.04; created a test pdf with the font Bitstream Charter using OO3.2.0. I was able to view it without any problems on WinXP - Adobe 10.0.1

I uninstalled the OO3.2.0

I then installed the LibreOffice 3.3.0 deb package (http://download.documentfoundation.org/libreoffice/old/stable/3.3.0/deb/x86/LibO_3.3.0_Linux_x86_install-deb_en-US.tar.gz) and tried it, the bug was present (dots when viewed on Win XP - Adobe 10.0.1)

I then installed OpenOffice 3.3.0 deb package (http://download.services.openoffice.org/files/stable/3.3.0/OOo_3.3.0_Linux_x86_install-deb_en-US.tar.gz) and the bug was still present.

So maybe a diff between OO 3.3.0 and OO 3.2.0 might lead us in the right direction.
Comment 9 Tad Whiteside 2011-05-04 18:30:09 UTC
This bug may have been caused by the patch to open office bug 87968:
http://openoffice.org/bugzilla/show_bug.cgi?id=87968

This was the only bug in the 3.3 updates that seemed to deal with pdfs (http://www.openoffice.org/dev_docs/features/3.3/index.html)
Comment 10 S. 2011-05-09 07:34:32 UTC
Hi guys, can we please mark this bug as confirmed? It is a very dangerous bug. It has resulted in me sending critical PDFs to end users, only to receive emails that they couldn't read the file. It would be very easy to miss deadlines or create a flood of emails from frustrated users when they receive an incompatible PDF file. I personally don't use Adobe Reader very often, but almost 100% of the rest of the world does.

Thanks!
Comment 11 cgwriting 2011-05-18 02:27:18 UTC
This is definitely a problem. This doesn't just affect PDFs opened by Acrobat Reader, it also occurs on a book file that I uploaded to a printer's system (Lightning Source). The error they see is a corrupted embedded font file.
Comment 12 Christopher M. Penalver 2011-05-18 09:35:37 UTC
Looks fixed in LO Beta 3.4.0 beta 5. Marking Resolved Fixed.

LibreOffice 3.4.0 DEV300m103(Build:5)

lsb_release -rd
Description:	Ubuntu 11.04
Release:	11.04

apt-cache policy acroread
acroread:
  Installed: 9.4.2-0maverick1
  Candidate: 9.4.2-0maverick1
  Version table:
 *** 9.4.2-0maverick1 0
        500 http://archive.canonical.com/ubuntu/ natty/partner i386 Packages
        100 /var/lib/dpkg/status
Comment 13 S. 2011-06-06 09:10:56 UTC
Confirmed fixed with 3.4.0 (official LibO RPMs) installed on openSUSE 11.4. Works with Bistream Charter fonts in a PDF exported by LibO and viewed on Adobe Reader for Linux.

Thanks so much!!
Comment 15 Caolán McNamara 2011-08-22 05:43:17 UTC
*** Bug 33703 has been marked as a duplicate of this bug. ***
Comment 16 Frédéric Buclin 2011-08-22 12:20:10 UTC
Also confirmed fixed with Nimbus Roman N°9L and LibO 3.4.2. Congratulations to Luboš! \o/
Comment 17 NoOp 2011-09-05 20:02:22 UTC
Inital test .odt exported w/ PDF/A still exhibits the original issue. I'll attach a PDF output.

LibreOffice 3.3.4 
OOO330m19 (Build:401)
tag libreoffice-3.3.4.1
$ cat /opt/libreoffice/program/versionrc
[Version]
AllLanguages=en-US
buildid=330m19(Build:401)
ExtensionUpdateURL=http://updateexte.libreoffice.org/ExtensionUpdateService/check.Update
OOOBaseVersion=3.3
ProductBuildid=401
ProductMajor=330
ProductMinor=19
ProductSource=OOO330
UpdateID=LibreOffice_3_en-US
UpdateURL=
UpdateUserAgent=<PRODUCT> (${buildid}; ${_OS}; ${_ARCH}; BundledLanguages=${AllLanguages})

(linux - 32bit)

Steps to reproduce;

Opened courier10pitch.odt
Exported as PDF/A-1a
Opened the resulting PDF in Adobe Reader 9.4.2

Result: Cannot extract the embedded font 'Courier10PitchBT-Roman'. Some characters may not display or print correctly.

Dots are shown instead of characters.

I believe this bug is related to:
https://bugs.freedesktop.org/show_bug.cgi?id=38347
[Exported PDF/A files cannot be opened in acroreader]
Comment 18 NoOp 2011-09-05 20:03:50 UTC
Created attachment 50929 [details]
Resulting pdf from courier10pitch_334.pdf w/334
Comment 19 joshua 2011-11-07 20:53:56 UTC
I'm having the exact same problem in LibO_3.4.3_Win_x86_install_multi.exe

This is a major problem... when/where is the fix?!
Comment 20 Luboš Luňák 2012-01-16 10:49:43 UTC
I cannot reproduce any problem on Linux with LibreOffice 3.4.4 and Acroread 9.4.6. Even 3.4.3 should have the fix, 3.3.x is too old though. Please check your version again, and you need to provide more details to reproduce the problem if it still persists for you.
Comment 21 Florian Reisinger 2012-08-14 13:59:23 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 22 Florian Reisinger 2012-08-14 14:00:34 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 23 Florian Reisinger 2012-08-14 14:05:16 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 24 Florian Reisinger 2012-08-14 14:07:19 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian