Download it now!
Bug 35498 - EDITING : OLE objects in PPT files cannot be edited/outplaced
Summary: EDITING : OLE objects in PPT files cannot be edited/outplaced
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) Linux (All)
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:ppt
Depends on:
Blocks: OLE-Objects PPT
  Show dependency treegraph
 
Reported: 2011-03-21 01:44 UTC by Gökçen Eraslan
Modified: 2020-06-04 22:13 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
PPT file containg OLE Chart, try to change values of the chart to reproduce the bug (140.00 KB, application/vnd.ms-powerpoint)
2011-03-21 01:44 UTC, Gökçen Eraslan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gökçen Eraslan 2011-03-21 01:44:35 UTC
Created attachment 44651 [details]
PPT file containg OLE Chart, try to change values of the chart to reproduce the bug

I want to change the data of an OLE Chart in a PPT file. When I double click on the OLE object to edit it, an empty Calc window is shown instead of the real data of the Chart (which is ). You can either select "OLE Object" or the "Outplace OLE object" option from the context menu of the chart to reproduce the bug.

To reproduce the bug, try to change the values of the pie chart.
Comment 1 Gökçen Eraslan 2011-03-23 11:27:37 UTC
Still reproducable in 3.3.2.2.
Comment 2 Björn Michaelsen 2011-12-23 11:48:51 UTC Comment hidden (obsolete)
Comment 3 Gökçen Eraslan 2012-04-05 06:33:22 UTC
Still reproducable in 3.5.2.1 via double clicking on the object.
Comment 4 A (Andy) 2013-04-24 21:59:46 UTC
the reported issue was for me not reproducible with LO 4.0.2.2 (Win7 Home, 64bit), but if I want to edit the graphs then not LO Calc is opened but Microsoft Graph
Comment 5 QA Administrators 2015-03-04 02:19:39 UTC Comment hidden (obsolete)
Comment 6 Gökçen Eraslan 2015-03-04 12:41:51 UTC
The behavior is still the same with Libreoffice 4.4.1.2 on ArchLinux, although "OLE Object" or the "Outplace OLE object" context menu options seem to be gone. Double clicking can be used to reproduce it.
Comment 7 tommy27 2016-04-16 07:26:31 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-05-22 13:22:29 UTC Comment hidden (obsolete)
Comment 9 Gökçen Eraslan 2017-05-23 08:45:18 UTC
Still reproducible with LO 5.3.3.2 on Arch linux. This bug existed in OOo 3.3 as well, so I changed the version to "Inherited from OOo".
Comment 10 QA Administrators 2018-10-22 02:50:47 UTC Comment hidden (obsolete)
Comment 11 Buovjaga 2019-08-23 11:22:24 UTC
Still confirmed (Microsoft Graph instead of Calc), let's change to enhancement

Version: 6.4.0.0.alpha0+ (x64)
Build ID: 3e64065612acec2eb29aa21e2b515953422256d7
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@62-TDF, Branch:master, Time: 2019-08-15_22:57:26
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded