Bug 35503 - Format cells -> Font hangs
Summary: Format cells -> Font hangs
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other Linux (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-21 06:13 UTC by Miklos Vajna
Modified: 2011-04-17 11:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2011-03-21 06:13:26 UTC
How to reproduce:

1. Create a new spreadsheet
2. Enter "aaa" (or something else) to the cell A1.
3. Right click -> Format cells.
4. Click the "Font" tab.

The UI now hangs, strace says:

$ strace -p 14088
Process 14088 attached - interrupt to quit
futex(0xa9d57bd8, FUTEX_WAIT, 14098, NULL

(I've tried several times, seems to be reproducible.)

This is on Frugalware, but I'm not sure if it's distro-specific:

$ grep font distro-configs/Frugalware.conf.in 
--without-fonts

If you have an idea what code part may be relevant, I'm happy to investigate, but I don't really know where to start. :)

Thanks.
Comment 1 Kohei Yoshida 2011-03-21 18:22:19 UTC
I can't reproduce this in my environment.  This is a very basic functionality, so if this was broken we'd be flooded with tons of bug reports, I would think.
Comment 2 Kohei Yoshida 2011-03-21 18:26:57 UTC
SvxCharNamePage is the class that implements the font panel.  It's in cui.  That should be a good starting point to debug this problem.
Comment 3 Kohei Yoshida 2011-03-21 18:28:35 UTC
I'll assign this to you, Miklos.
Comment 4 Miklos Vajna 2011-03-22 01:50:58 UTC
OK, thanks for the pointer. I can't reproduce this with 3.3.0.4 on an other machine, I'll try to find out if it's really 3.3.0 vs 3.3.1, or some other system library differs that causes the hang.
Comment 5 Miklos Vajna 2011-03-23 04:39:19 UTC
FWIW, it seems to be related to cups:

(gdb) bt
#0  0xb77e3430 in __kernel_vsyscall ()
#1  0xb7126dee in pthread_join () from /lib/libpthread.so.0
#2  0xb76428d4 in osl_joinWithThread ()
   from /home/vmiklos/git/libreoffice/master/install/program/../basis-link/ure-link/lib/libuno_sal.so.3
#3  0xb61a6d39 in psp::CUPSManager::checkPrintersChanged(bool) ()
   from /home/vmiklos/git/libreoffice/master/install/program/../basis-link/program/libvclli.so
#4  0xb2177104 in X11SalInstance::GetPrinterQueueInfo(ImplPrnQueueList*) ()
   from /home/vmiklos/git/libreoffice/master/install/basis3.3/program/libvclplug_genli.so
#5  0xb6059a52 in ImplInitPrnQueueList() () from /home/vmiklos/git/libreoffice/master/install/program/../basis-link/program/libvclli.so
#6  0xb6059aee in Printer::ImplGetQueueInfo(String const&, String const*) ()
   from /home/vmiklos/git/libreoffice/master/install/program/../basis-link/program/libvclli.so
#7  0xb605a199 in Printer::Printer() () from /home/vmiklos/git/libreoffice/master/install/program/../basis-link/program/libvclli.so
#8  0xae451066 in SvxFontPrevWindow::SvxFontPrevWindow(Window*, ResId const&) ()
   from /home/vmiklos/git/libreoffice/master/install/program/../basis-link/program/libsvxli.so
#9  0xac442f68 in SvxCharBasePage::SvxCharBasePage(Window*, ResId const&, SfxItemSet const&, unsigned short, unsigned short) ()
   from /home/vmiklos/git/libreoffice/master/install/basis3.3/program/libcuili.so
#10 0xac4489ff in SvxCharEffectsPage::SvxCharEffectsPage(Window*, SfxItemSet const&) ()
   from /home/vmiklos/git/libreoffice/master/install/basis3.3/program/libcuili.so

I mean if cups is not running, I don't get the hang.
Comment 6 Miklos Vajna 2011-04-17 11:54:12 UTC
It turns out this wasn't a bug in LO itself, but in libcups, marking as 'invalid'. Sorry for the noise. :)