Bug Hunting Session
Bug 35567 - LibreOffice Calc does not have a nice Linear Regression tool
Summary: LibreOffice Calc does not have a nice Linear Regression tool
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Enhancements Calc-Function
  Show dependency treegraph
 
Reported: 2011-03-22 14:14 UTC by dajoker
Modified: 2018-07-29 18:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dajoker 2011-03-22 14:14:29 UTC
OpenSUSE 11.3 x86-64
LibreOffice 3.3.1

I've been enjoying using LibreOffice this last couple of weeks instead of OpenOffice but in class today the instructor took us through linear regression.  While I have found the LINEST tool it's not quite the same experience as some other productivity suites provide.  I'm using Gnumeric's linear regression option successfully and that's okay but I'd rather do this natively within OpenOffice.  Selling my classmates on LibreOffice hasn't been too hard since it's done almost everything they have been able to do without any issues (have been some problems with microsoft's proprietary XML format rendering in odd cases, but that's it so far) but most of them are not on Linux so using Gnumeric isn't an option.

I'm willing to test what anybody comes up with or even help with creating it but I must admit I'm no statistician.

Expected Results: Linear Regression tool that is simple to use and powerful.

Actual Results: LINEST function does some of this but not in an easy-to-use way, and without as many data points in the output.
Comment 1 Regina Henschel 2011-03-24 15:22:59 UTC
Please be more specific about what you are missing and what you get in Gnumeric and not in Calc.
Comment 2 dajoker 2011-03-24 20:06:50 UTC
Output like the following by running a quick tool that just selects the independent and dependent variables' data, plus provides other options.  This is similar to what is provided with other proprietary packages and, as far as I know, is not part of OO.o or LO.  Sorry about the spacing:

SUMMARY OUTPUT		Response Variable:	GE			
						
Regression Statistics						
Multiple R	0.8117049					
R^2	0.658865					
Standard Error	0.061578					
Adjusted R^2	0.652983					
Observations	60					
						
ANOVA						
	df	SS	MS	F	Significance of F	
Regression	1	0.424772	0.424772	112.0206	3.63E−15	
Residual	58	0.219931	0.003792			
Total	59	0.644702				
						
	Coefficients	Standard Error	t-Statistics	p-Value	Lower 95%	Upper 95%
Intercept	−0.00201	0.007955	−0.25203	0.801906	−0.01793	0.01392
S&P	1.642878	0.155223	10.58398	3.63E−15	1.332165	1.95359
Comment 3 Regina Henschel 2011-06-14 10:07:24 UTC
You can get all the needed values using LINEST. I do not think, that LO should integrate such a wizard. Such wizard can be provided by an extension. Please have a look at http://openoffice.org/projects/sc/downloads/download/Data%20Analysis/Statistical%20data%20analysis%20tool.zip
[I don't know whether it is on the extensions-website, because it is down currently.]
Comment 4 Björn Michaelsen 2011-12-23 11:43:36 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 13:57:44 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 13:59:04 UTC Comment hidden (obsolete)
Comment 7 Florian Reisinger 2012-08-14 14:03:36 UTC Comment hidden (obsolete)
Comment 8 Florian Reisinger 2012-08-14 14:05:52 UTC Comment hidden (obsolete)
Comment 9 dajoker 2012-08-14 17:03:01 UTC
To resolve the NEEDINFO state, there is still no advanced/nice linear regression tool in LO as far as i can tell.
Comment 10 Roman Kuznetsov 2018-07-29 17:41:40 UTC
There is Data->Statistics->Regression now in LO 6.1.

I don't know is it nice tool or not, but it there is.

Regina, what do you think? May be close this enhacement as WFM?
Comment 11 Regina Henschel 2018-07-29 18:53:23 UTC
Yes, it can be closed. In case the existing tool needs to be improved, a new bug report is necessary anyway.