Bug 35574 - doc with embedded tables formatting issues
Summary: doc with embedded tables formatting issues
Status: NEEDINFO
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Tables
  Show dependency treegraph
 
Reported: 2011-03-22 17:01 UTC by digital ant
Modified: 2020-04-20 10:31 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
word doc with tables and pdf (73.02 KB, application/zip)
2011-03-22 17:01 UTC, digital ant
Details
PDF printed using 4.5 alpha from 19 Jan 2015 (136.12 KB, application/pdf)
2015-01-22 13:35 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description digital ant 2011-03-22 17:01:33 UTC
Created attachment 44733 [details]
word doc with tables and pdf

Have verified this in both 3.3.0 release and 3.3.2 release on Win 7 64 bit, Ubuntu 10.04 x86, Mac OSX Leopard Intel, and Windows XP Pro SP3 x86.

The doc file in attached zip was created in M$ office 2007 and the pdf was generated to show correct formatting. Open doc in LibreOffice and notice table formatting issues. We have tried on all varieties of OS with many different font packages installed. Java versions installed are current.

Both windows boxes have office fonts loaded from ppt viewer, and Ubuntu and Mac boxes are running mscorefonts packages.

On Windows, tried with 3.3.0 release, uninstalled, cleared profile, cleaned registry, loaded 3.3.2 and received same results. On OSX, tried with 3.3.0, removed app, removed LibO folder in user library, secure erased trash, loaded 3.3.2 with same result.
Comment 1 Björn Michaelsen 2011-12-23 11:49:23 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 14:01:55 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:02:57 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:07:31 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:09:37 UTC Comment hidden (obsolete)
Comment 6 sasha.libreoffice 2012-08-30 09:14:38 UTC
Reproduced in 3.3.4 and 3.6.1 on Fedora 64 bit
Comment 7 QA Administrators 2015-01-05 17:51:20 UTC Comment hidden (obsolete)
Comment 8 Buovjaga 2015-01-22 13:35:59 UTC
Created attachment 112662 [details]
PDF printed using 4.5 alpha from 19 Jan 2015

PDF export showing problems persist.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 07e84cae983c08afdba03018413a19d01abb3006
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-19_06:15:38
Comment 9 QA Administrators 2016-02-21 08:35:14 UTC Comment hidden (obsolete)
Comment 10 Eyal Rozenberg 2018-01-07 19:45:24 UTC
Still seeing this with LO 6.0.0.1 RC.
Comment 11 QA Administrators 2019-01-08 03:42:52 UTC Comment hidden (spam)
Comment 12 Eyal Rozenberg 2020-01-20 22:53:06 UTC
It is not clear to me that what we're seeing in LO is the result of table formatting issues, as opposed to frame positioning, application of styles not in the way MS-Word would, etc.

So, while I still see the inappropriate rendering, I'm changing the status to NEEDINFO.

Reporter, or others - please do the following:

* Identify a list of distinct formatting/layout issues.
* For each layout issue with the file, try removing as much as you can from the file's contents while still maintaining the issue manifestation.
* Please go over the various issues mentioned in the blocked META bug, bug 112700, to filter out already-reported bugs.
* File each of the issues separately (but don't re-file for multiple examples of the same issue).
Comment 13 Peter 2020-04-04 11:43:04 UTC
Hej!
I can reproduce this in Libreoffice 6.4.2-2 under Linux 5.5.13 (although I am sure that is not relevant, since the bug was first reported 2011).

Just to make sure, everyone is talking about the same bug, here is a visual depiction. The document before saving:

https://github.com/p3732/various/raw/master/libreoffice/table%20layout/preview_intended.png

The document after saving and reopening:

https://github.com/p3732/various/raw/master/libreoffice/table%20layout/preview_actual.png

I tried some things starting from an empty document and came to the following conclusions:

* The bug only occurs when font embedding is limited to "Only embed fonts that are used in documents"

* The bug does not occur when there is no text and thus no fonts to include

* The bug is an odt (and ott) format bug, since it does not happen for doc, docx or uot formats

* It effects all properties of a table, including size and column positioning.

I uploaded a bunch of test files (https://github.com/p3732/various/tree/master/libreoffice/table%20layout), but I suppose reproducibilty is not an issue.
If there is anything I can do to help, let me know :)
Comment 14 Justin L 2020-04-20 10:31:59 UTC
I am specifically focusing on the really messed up section for "Internet products/Cable products". I used Word 2003 to save as DOCX format (which opens up pretty decent in LO), and then I again used Word 2003 to save the DOCX back to .doc format (in order to ensure any corrupts are fixed up). LO opens up that round-tripped file pretty decent. [I'm not sure that proves anything, since a simple roundtrip without changing the format in the middle shows the same problem.]