Download it now!
Bug 35643 - Debug Watch fails to handle Type Records correctly.
Summary: Debug Watch fails to handle Type Records correctly.
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium normal
Assignee: Jens Carl
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Macro-StarBasic
  Show dependency treegraph
 
Reported: 2011-03-24 22:24 UTC by jmg
Modified: 2019-11-22 09:02 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jmg 2011-03-24 22:24:04 UTC
It nearly gets it right.

If I declare
Type EmployeeRecord
	strEmpName As String
	dtmHireDate As Date
	sngHourlyRate As Single
End Type

Type IntRecT
	IntA As Integer
	IntB As Integer
End Type


Dim TestER(5) as EmployeeRecord
Dim IntRec(5) as IntRecT

 Then I can set watch of TestER, or IntRec, and they show as (5), but the elements are not visible.
 They do display as TestER(2)[+], suggesting more info, but the [+] does nothing ?

 Is that as good as watch performs, on a Record structure ?
 Even a simple two-integer record, fails to watch correctly ?
 or did I miss some setup ?
Comment 1 Björn Michaelsen 2011-12-23 11:43:29 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 13:57:39 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 13:58:59 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:03:32 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:05:47 UTC Comment hidden (obsolete)
Comment 6 sasha.libreoffice 2012-08-30 10:56:40 UTC
reproduced in 3.6.1 on Fedora 64 bit
Comment 7 QA Administrators 2015-07-18 17:42:50 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2016-09-20 10:18:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.1.5 or 5.2.1  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20160920