Bug 35717 - Error installing Estonian language pack
Summary: Error installing Estonian language pack
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-27 05:52 UTC by Peeter
Modified: 2013-02-24 14:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Peeter 2011-03-27 05:52:07 UTC
OS: Mac OS X 10.6.7

After successful install of LibO_3.3.2_MacOS_x86_install_en-US.dmg I tried to install the language pack LibO_3.3.2_MacOS_x86_langpack_et.dmg, but after double-clicking LibreOffice 3.3 Language Pack.app in the installation package I can only see it's icon in the Dock for a moment, nothing else happens.

If I open it in the terminal, I get the following error:

$ open LibreOffice\ 3.3\ Language\ Pack.app/
LSOpenURLsWithRole() failed with error -10810 for the file /Users/myusername/Downloads/LibreOffice 3.3 Language Pack.app.
Comment 1 Thorsten Behrens (CIB) 2011-06-29 02:50:40 UTC
See also bug 35121 and bug 33682 for potentially related problems. Fridrich, can you reproduce the problem?
Comment 2 Peeter 2011-06-29 03:45:56 UTC
I just installed LibreOffice 3.4.0 and also the Estonian language pack. The spell checking works.

Estonian is not listed in user interface languages, but I guess that it is not available at the moment.

What I did:
1. Installed LibreOffice.
2. Opened LibreOffice Language Pack.app in the mounted .dmg language pack file. Nothing seemed to happen.
3. Opened LibreOffice Language Pack.app in the terminal. It's icon began to pop in the dock. After some time the icon disappeared.
4. Opened LibreOffice. The spell checking for Estonian already worked without the need to set it in the preferences.
Comment 3 Roman Eisele 2012-09-20 10:32:31 UTC
Bug was never confirmed by a reviewer, therefore reset Status to UNCONFIRMED.

(No offence -- this does not mean that I doubt the existentence of this bug -- when status is UNCONFIRMED, the chance is even better that a bugwrangler will try to reproduce this issue or search for duplicates, while with Status NEW the bug will probably just be overlooked.)
Comment 4 Roman Eisele 2012-09-20 10:35:41 UTC
Additional hint: on the first glance, comment #2 looks like WORKSFORME, but if I understand correctly, the error was still present:

> 2. Opened LibreOffice Language Pack.app in the mounted .dmg language pack file.
> Nothing seemed to happen.
> 3. Opened LibreOffice Language Pack.app in the terminal. It's icon began to pop
> in the dock. After some time the icon disappeared.

So the langpack installer still did not work in the normal way.
Comment 5 Peeter 2012-09-30 12:40:01 UTC
I previously thought that the package adds also spell checking. So you can omit that part.

The language pack still does not work for LibreOffice 3.6.1.2 indeed.

After double-clicking 'LibreOffice Language Pack.app' the app just pops up for a second in the Dock, but nothing happens. Console shows the following message:

30.09.12 15:30.28,162 com.apple.launchd.peruser.501[128]: ([0x0-0x669669].org.libreoffice.script[21268]) Exited with code: 1

Opening the app in Terminal as regular user does nothing, but with sudo just prints the message:

LSOpenURLsWithRole() failed with error -10810 for the file /Users/peeter/Downloads/LibreOffice Language Pack.app.
Comment 6 Alex Thurgood 2012-10-04 09:08:04 UTC
Try this :

Open the DMG file.

Copy the app file to your desktop.

In a terminal :
chmod a+x /Users/peeter/Downloads/LibreOffice Language Pack.app

your chmod instruction needs to affect the contents of the app bundle so that the actual executable file (applescript file) becomes executable. Apparently, just chmod'ing the app file itself will not do this.

See, for example :
http://qt-project.org/forums/viewthread/14480

https://github.com/adobe/brackets/issues/1158





Alex
Comment 7 Alex Thurgood 2012-10-04 09:09:20 UTC
(In reply to comment #6)

Corrigendum:

> 
> In a terminal :
> chmod a+x /Users/peeter/Desktop/LibreOffice Language Pack.app
>
Comment 8 Roman Eisele 2012-10-04 10:04:13 UTC
@ Alex:

Wow -- does chmod a+x really do the trick? If yes, your workaround could be the key for fixing the issues with PPC langpack installers (cf. bug 43392): maybe it is just a problem with wrong file mode bits? Then it should be rather easy to fix it in the installer ...
Comment 9 Peeter 2012-10-04 10:10:20 UTC
(In reply to comment #7)
> (In reply to comment #6)
> 
> Corrigendum:
> 
> > 
> > In a terminal :
> > chmod a+x /Users/peeter/Desktop/LibreOffice Language Pack.app
> >

Since the filename contains spaces, it should be actually
chmod a+x "/Users/peeter/Desktop/LibreOffice Language Pack.app"

Unfortunately it does not work. It gives the same error.

Have not read linked examples yet for possible additional notes.
Comment 10 Peeter 2012-10-04 10:14:42 UTC
(In reply to comment #5)
> Opening the app in Terminal as regular user does nothing, but with sudo just
> prints the message:
> 
> LSOpenURLsWithRole() failed with error -10810 for the file
> /Users/peeter/Downloads/LibreOffice Language Pack.app.

Now the only difference is that if I open the app in Terminal as a regular user, I get the same error as with using sudo. Previously nothing happened when I opened it as the regular user.
Comment 11 Alex Thurgood 2012-10-04 14:04:21 UTC
(In reply to comment #10)
> (In reply to comment #5)
> > Opening the app in Terminal as regular user does nothing, but with sudo just
> > prints the message:
> > 
> > LSOpenURLsWithRole() failed with error -10810 for the file
> > /Users/peeter/Downloads/LibreOffice Language Pack.app.
> 
> Now the only difference is that if I open the app in Terminal as a regular
> user, I get the same error as with using sudo. Previously nothing happened
> when I opened it as the regular user.


Peeter,

Did you reset all of permissions of the files included in the app bundle or just the app bundle folder ?


Alex
Comment 12 Alex Thurgood 2012-10-04 14:06:48 UTC
I'm not saying that this actually works, because I've never had the problem on any of the Macs to which I have access, but this is one suggested way of dealing with similar problems giving identical error messages in other app bundles.



Alex
Comment 13 Florian Reisinger 2013-02-24 08:31:15 UTC
Does it work with a current version?
Comment 14 Peeter 2013-02-24 10:42:38 UTC
(In reply to comment #13)
> Does it work with a current version?

Thank you! I just tried out and it works perfectly in LibreOffice 4.
Comment 15 Florian Reisinger 2013-02-24 14:15:14 UTC
Changed status --> No fix known (WORKSFORME) (Thanks for the quick answer)
Comment 16 Peeter 2013-02-24 14:27:23 UTC
(In reply to comment #11)
> Did you reset all of permissions of the files included in the app bundle or
> just the app bundle folder ?

If I remember correctly I tried to reset all of permissions of the files included in the app bundle as well, but without result. I gave up and postponed investigating it future soon after that.