Download it now!
Bug 35742 - Video and audio with not ascii filenames or path don't play
Summary: Video and audio with not ascii filenames or path don't play
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.1 RC1
Hardware: All Linux (All)
: medium normal
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-28 08:19 UTC by adilalou
Modified: 2015-04-23 15:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description adilalou 2011-03-28 08:19:11 UTC
I insert video and audio in libreoffice 3.3.1 but it doesn't play anything if the filename has non ascii characters or if there are non ascii characters in the path. I tried with mp3 and avi files.
Comment 1 RGB 2011-05-06 15:12:11 UTC
I can confirm the problem on both, 3.3.2 and 3.4 beta. If I have a video on the folder ~/Vídeo (with a diacritic on the i -the correct Spanish spelling) LibO do not play it, but if I copy the same video to another location without diacritics on path, it works without problems.
I must add that when the video is on the location with diacritics LibO do not show error messages or warnings: it just do nothing with the video.
Comment 2 Noel Power 2011-05-09 03:08:36 UTC
probably a simple string decoding problem somewhere along the line ( worse it works with the oracle version ) Radek, can you have a look
Comment 3 QA Administrators 2015-04-01 14:41:35 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 4 Buovjaga 2015-04-23 15:14:23 UTC
To make sure, I had a folder named í and a file named í.wav inside it, inserted to Impress and it played fine. WFM.

Ubuntu 14.10 64-bit 
Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-04-22_00:50:58
Locale: en_US