Bug Hunting Session
Bug 35836 - Writer form does not save control data properties
Summary: Writer form does not save control data properties
Status: RESOLVED DUPLICATE of bug 50097
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.1 release
Hardware: All Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-31 07:14 UTC by C. Andrews Lavarre
Modified: 2016-06-15 08:40 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
test case for saving controls (9.74 KB, application/vnd.oasis.opendocument.text)
2012-11-26 05:32 UTC, sasha.libreoffice
Details
Save button does not show when changing properties (13.33 KB, application/vnd.oasis.opendocument.text)
2015-07-14 03:38 UTC, Óvári
Details

Note You need to log in before you can comment on or make changes to this bug.
Description C. Andrews Lavarre 2011-03-31 07:14:31 UTC
LibreOffice: LibreOffice 3.3.1
OOO330m19 (Build:8)
tag libreoffice-3.3.1.2

on KDE 4.6 openSUSE 11.4

Apparently I cannot save database properties for controls on a database form written in Writer. 

+ I've created a document in Writer, populated it with controls (text boxes and check boxes).
+ I' ve created a database in Base, and used Edit > Exchange Databases > Select > Define to identify the database to Write,.
+ I then use Design Mode ON with the form properties box to assign a table in the database to the form.
+ Finally, for each control I use use Design Mode ON with the control properties box to assign a field in the table in the database to the control.

I can now navigated the database table and its fields, edit entries, show each record in the form, etc. Everything works as expected (based on prior MS Access experience). All good.

+ So I save the form, close down, and reload the form. Poof! Gone! The form has not retained its database table assignment. None of the controls have retained their database table field assignments. None of the other database properties (NULL, Input Required) have been saved and some of the General properties (Tab Stop, Tab Order) have been lost.

REPRODUCIBLE: Always
Comment 1 C. Andrews Lavarre 2011-03-31 07:24:33 UTC
Can provide test case *.odb and *.doc on request (tried uploading as attachment but they are too  big).
Comment 2 C. Andrews Lavarre 2011-03-31 17:51:58 UTC
Aha! The properties are saved when saving AS AN ODT but are not saved when SAVING AS A DOC.

So you should first save your document as a LibreOffice document (ODT) and then if you want it in MS format then save it as a DOC, but rest assured the properties will not be saved with it.

You may degrade this status, but it should be fixed in due course so that the properties that are saved in Libre Office also are saved in the MS format...

Cheers, Andy
Comment 3 Björn Michaelsen 2011-12-23 11:50:41 UTC Comment hidden (obsolete)
Comment 4 sasha.libreoffice 2012-01-05 01:27:35 UTC
reproduced on LibO 3.5.0 beta 1
but it possible save in doc format forms?
Comment 5 Florian Reisinger 2012-02-25 08:37:42 UTC
Changed Version from 3.3.1 to 3.5b1
Bug seems to be confirmed....
Comment 6 sasha.libreoffice 2012-02-27 01:10:32 UTC
@ Florian Reisinger
"Version" - most old version of LibreOffice where bug reproducible, not current version (if in current version of LO would not reproducible, bug should be closed)
Please, revert again to 3.1
Comment 7 Jean-Baptiste Faure 2012-11-24 15:41:39 UTC
Reset to version 3.3.1

@Reporter: could you try again with current release 3.6.3. Indeed many improvements in MS-Word export have been done since the first release of LibreOffice.

Thank you very much for your help. 
JBF
Comment 8 C. Andrews Lavarre 2012-11-24 21:47:04 UTC
LibreOffice 3.5:build-403 
Build ID: 350m1(Build:403)

Jean Baptiste said:

>@Reporter: could you try again with current release 3.6.3. Indeed many
improvements in MS-Word export have been done since the first release of
LibreOffice.

Hello, thank you for the followup. The latest version available in the openSUSE 12.2 repositories is 3.5.4.7-1.1.2, which I have installed.

As I use it for production I'll have to wait until 3.6.3 appears.

In this version (3.5.4.7-1.1.2) the problem remains:

Saving to: 
+ ODT     saves correctly
+ DOCX    saves as a blank document (does not crash)
+ DOC     crashes the entire suite (ODT, XLS, anything that is open)

Best regards, Andy
Comment 9 Jean-Baptiste Faure 2012-11-25 07:20:34 UTC
Please, do not change the version number, it gives the oldest version in which the problem has been found.

Could you attach a sample document in odt format with all things needed to do test in newer versions? 

Best regards. JBF
Comment 10 C. Andrews Lavarre 2012-11-26 00:12:53 UTC
Sorry about the version, I was trying to help.

I have posted the files in question (too big to upload here) to:

     https://docs.google.com/a/lavarre.org/folder/d/0BxyqJFl_DI8sMWtLcF9OZjMtTHc/edit

(all one line) which I have shared with 

     jbf.faure@sud-ouest.org

If that doesn't work for you then I'll work at shrinking the files and send them to you at the last email address if you wish.

There are three files:

     psycheval.odt
     121124_psycheval.odt
     121124_psycheval.docx

I open 

     psycheval.odt

and enter data, then save it as:

     121124_psycheval.odt

which is correctly saved with the entered data (JOe Smith, etc.)

I then file > save as > 

     121124_psycheval.docx

that as you can see is blank.

Then I file . save as > 

     121124_psycheval.doc

and the entire application crashes.

Thanks in advance.

Yes, the files are rather large due to the underlying graphic of the treatment form. 

That may be part of the problem.

I can experiment with that, but the point is that it saves correctly as odt but not as either docx or doc.

Kind regards, Andy
Comment 11 sasha.libreoffice 2012-11-26 05:32:47 UTC
Created attachment 70566 [details]
test case for saving controls

This attachment in 3.6.3 saved correctly to doc, but saving to docx appears without controls at all
Comment 12 sasha.libreoffice 2012-11-26 05:35:07 UTC
may be the same problem: Bug 50097 and Bug 54235
Comment 13 Alex Thurgood 2015-01-03 17:40:37 UTC Comment hidden (no-value)
Comment 14 Joel Madero 2015-02-09 04:48:33 UTC
Removing love keyword as it never really caught on and it duplicates what "EasyHack" means (code pointer + dev willing to assist if needed).
Comment 15 Óvári 2015-07-14 03:38:37 UTC
Created attachment 117221 [details]
Save button does not show when changing properties

Save button does not show in File menu or Standard toolbar when changing the properties of a form control
Comment 16 Alex Thurgood 2016-06-15 08:40:15 UTC

*** This bug has been marked as a duplicate of bug 50097 ***