Bug 35922 - Image cropping + mirroring + rotation do not play well together
Summary: Image cropping + mirroring + rotation do not play well together
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 65684 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-03 02:21 UTC by sergio.callegari
Modified: 2015-04-02 08:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file (open and rotate the image to trigger the bug) (209.90 KB, application/vnd.oasis.opendocument.presentation)
2011-04-03 02:21 UTC, sergio.callegari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sergio.callegari 2011-04-03 02:21:07 UTC
The following is giving me trouble

1) Import a bitmap image
2) Crop the image to remove a part of it
3) Rotate the image 90°
4) Mirror the image horizontally

As a result of the last step the image disappears.

This also happens if step 3 and 4 are swapped.
Please test with the attached test.odp by rotating the image 90°.

Bug also exist in openoffice.org 3.3.
Bug is most likely a regression since I have discovered it by opening an old document. When the old document was created it was ok, now an image is not displayed or displayed at a wrong place. Cannot say when the original document was created, but most likely when openoffice was at version 3.0 or 3.1.
Comment 1 sergio.callegari 2011-04-03 02:21:54 UTC
Created attachment 45170 [details]
test file (open and rotate the image to trigger the bug)
Comment 2 djosiasmp 2011-10-05 17:35:57 UTC
I can confirm this.

Running LibreOffice 3.4.3 on WinXP.
The bug also appears in LO Draw exactly as described below.

It also will disappear if you do the following:
1)import bitmap
2)crop
3.1)flip vertical -> IMAGE DISAPPEARS
3.2)flip horizontal -> image remains but is OFFSET
4) rotate -> IMAGE DISAPPEARS from page but is somewhat visible on the page pane

Sometimes expanding the crop box to about twice the size of the page will make it appear in a corner.

It might be related to Bug 37905 - UI: Interactive cropping fails at rotated images in Impress
Comment 3 Björn Michaelsen 2011-12-23 11:51:05 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 sergio.callegari 2011-12-27 03:31:41 UTC
Confirmed in 3.5 beta 2
Comment 5 Korrawit Pruegsanusak 2012-04-15 06:23:38 UTC
Thanks for the bug report :-) but I just set back 'Version' field to '3.3.2 Release'. This field should be the *earliest* version the problem is found.
Comment 6 A (Andy) 2013-04-27 07:50:22 UTC
reproducible with LO 4.0.2.2 (Win7 Home, 64bit)
Comment 7 tommy27 2013-09-23 21:17:35 UTC
big was inherited from OOo and affects Windows as well and is still reproducible in 4.1.1.2
Comment 8 tommy27 2013-09-23 21:18:38 UTC
*** Bug 65684 has been marked as a duplicate of this bug. ***
Comment 9 QA Administrators 2015-04-01 14:41:28 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 10 sergio.callegari 2015-04-02 08:15:51 UTC
Seems fixed, thanks, please close