Bug 35973 - Remember the state of the sidebar and task pane in Impress
Summary: Remember the state of the sidebar and task pane in Impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium enhancement
Assignee: Rob Snelders
QA Contact:
URL: http://askubuntu.com/questions/82246/...
Whiteboard: target:3.7.0
Keywords: easyHack
: 43043 48488 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-04-04 19:47 UTC by Jean-François Fortin Tam
Modified: 2015-12-18 09:59 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Patch to solve the problem for the slidesorter-toolbar (44.75 KB, patch)
2012-05-24 13:48 UTC, Rob Snelders
Details
Remembers the stat of the slidesorter sidebar (38.34 KB, patch)
2012-05-25 08:33 UTC, Rob Snelders
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2011-04-04 19:47:45 UTC
I never use the stuff in the sidebar on the right... yet, everytime I start impress, it will be shown.

Instead, it should remember if I left it hidden last time.
Comment 1 Jean-François Fortin Tam 2011-04-04 19:50:18 UTC
I'll add that this is one of the mosty annoying issues I have with Impress' user interface, and that it probably is trivial to fix, so adding the EasyHack title.

While we're at it, the state of the left sidebar (the one containing the slides) could be remembered too.
Comment 2 Rob Snelders 2011-05-30 13:19:12 UTC
I'm going to try to fix it
Comment 3 Rob Snelders 2011-06-17 09:49:04 UTC
When you comment out lines 152 till 156 of file sd/source/ui/framework/module/ToolPanelModule.cxx then the sidebar on the right won't show after startup.
The following text is on those lines.

    pResourceManager->AddActiveMainView(FrameworkHelper::msImpressViewURL);
    pResourceManager->AddActiveMainView(FrameworkHelper::msNotesViewURL);
    pResourceManager->AddActiveMainView(FrameworkHelper::msHandoutViewURL);
    pResourceManager->AddActiveMainView(FrameworkHelper::msSlideSorterURL);

When you comment out lines 67 till 72 of file sd/source/ui/framework/module/SlideSorterModule.cxx then the sidebar on the left won't show after startup.
The following text is on those lines.

        AddActiveMainView(FrameworkHelper::msImpressViewURL);
        AddActiveMainView(FrameworkHelper::msOutlineViewURL);
        AddActiveMainView(FrameworkHelper::msNotesViewURL);
        
        AddActiveMainView(FrameworkHelper::msDrawViewURL);

I'll work on to try to make a configurable item from it so it remembers the last state.
Comment 4 Björn Michaelsen 2012-01-19 04:31:10 UTC
Any progress on this?
Comment 5 Rob Snelders 2012-01-24 11:24:30 UTC
I'm trying to solve this but I didn't work on it for a while.

I've added the config-values to my code-base, and try to use the configmgr/configitem. But I can't get it to work correctly yet. I'm sorry for the delays with this bug.
Comment 6 Rob Snelders 2012-05-24 13:48:00 UTC
Created attachment 62077 [details]
Patch to solve the problem for the slidesorter-toolbar

Send this to the developers-list. When this is accepted then I'll create the patch for the toolpanel-toolbar.
Comment 7 Rob Snelders 2012-05-25 08:33:21 UTC
Created attachment 62103 [details]
Remembers the stat of the slidesorter sidebar

new version of the patch
Comment 8 Thorsten Behrens (CIB) 2012-07-26 16:17:51 UTC
(In reply to comment #7)
> Created attachment 62103 [details] [review]
> Remembers the stat of the slidesorter sidebar
> 
> new version of the patch
>
Running a test build with it -
Comment 9 Thorsten Behrens (CIB) 2012-07-26 19:40:14 UTC
(In reply to comment #8)
> Running a test build with it -
>
And works nicely. Pushed to master. Rob, anything left doing here?
Comment 10 Thorsten Behrens (CIB) 2012-07-26 19:40:56 UTC
Comment on attachment 62103 [details]
Remembers the stat of the slidesorter sidebar

Marked patch obsolete, as this is pushed. Bug will then not show up in open patch queries.
Comment 11 Rob Snelders 2012-07-26 22:36:03 UTC
If this is accepted I need to do the same with the task-pane.
Comment 12 Stéphane Aulery 2012-08-11 01:26:47 UTC
Deteted "Easyhack" from summary
Comment 13 Rob Snelders 2012-09-01 12:03:27 UTC
committed a patch to gerrit to remember the state of the toolpanel.
https://gerrit.libreoffice.org/#/c/526/
Comment 14 Not Assigned 2012-09-14 14:40:33 UTC
Rob Snelders committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fb42827f323cec964cbbed3a86f9514ea62b1060

- fdo#35973 - Remember the state of the sidebar pane in Impress (ToolPanel)



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 15 Rob Snelders 2012-11-05 22:42:19 UTC
*** Bug 48488 has been marked as a duplicate of this bug. ***
Comment 16 Rob Snelders 2012-11-09 20:52:46 UTC
*** Bug 43043 has been marked as a duplicate of this bug. ***
Comment 17 Robinson Tryon (qubit) 2015-12-18 09:59:12 UTC
Migrating Whiteboard tags to Keywords: (EasyHack)
[NinjaEdit]