Download it now!
Bug 36091 - Bringing up dialogue for a different language for selection or paragraph only brings up text formatting instead
Summary: Bringing up dialogue for a different language for selection or paragraph only...
Status: RESOLVED DUPLICATE of bug 32780
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: PowerPC Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-08 18:25 UTC by cfr
Modified: 2014-08-20 11:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description cfr 2011-04-08 18:25:02 UTC
What happens:

[From menu bar]
Offer > Iaith > For Selection > More...
Offer > Iaith > For Paragraph > More...
[Translations:
 Offer - Tools
 Iaith - Language]

[Contextual menu for misspelling]
Set Language for Selection > More...
Set Language for Paragraph > More...

Any of these four will bring up a dialogue titled 'Nod' which controls the formatting of the text. I'm not sure what the English is. ('Nod' can be 'Note' but I'm not sure that's the sense here!) (My Welsh isn't great!) But it allows you to choose font, font effects, positioning (subscript, superscript etc.), hyperlinks and background colour.

In contrast:
Offer > Iaith > For all Text > More...
brings up a dialogue for controlling language options, spelling etc.

What I'd expect to happen:

I'd expect the "More..." in the other cases to let me select a language for the selection or paragraph which is not in my default list.

Mac OS X 10.4.11 on PPC G4 1.5 GHz
Comment 1 manj_k 2011-06-05 05:28:17 UTC
I think that's the correct behaviour.
It's the same dialogue as 'Menu Format > Character' 

There's a dropdown list box 'Language' in the 'Font' tab, with all available languages (where you can select the desired language).

See also:
'Bug 37919 - Clicking "more" on the Language Section in Writer at the bottom bar opens up the wrong Dialog Window'

'Bug 32780 - Character dialog box opens when click on "Tools > Language > For the selection > Plus.."'

My proposal: RESOLVED NOTABUG
Comment 2 Johannes Buchner 2014-08-20 11:04:57 UTC
It is the same behaviour as clicking 
  Tools -> Language -> For Selection or For Paragraph -> More ...

However, as you can see from the bug reports, this is surprising to the user, because when in a language context, you do not want to change the font or colors. You want to change the language.

It would thus be more sensible to follow the behaviour as if clicking 
  Tools -> Language -> All text -> More ...
and bring up the options dialog.

I see now that in Bug 32780 comment 1 there is some explaination, specifically that the language can be changed in the "Font" tab. Then, the bug is that this tab is not activated by default, and this behaviour should be changed.
Comment 3 Johannes Buchner 2014-08-20 11:10:46 UTC
I comment on this problem in Bug 32780, which seems to be the first bug-report, so conversation should be there.

*** This bug has been marked as a duplicate of bug 32780 ***