Bug 36157 - DBF can not open from cifs/smb
Summary: DBF can not open from cifs/smb
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-12 05:21 UTC by Vitaliy
Modified: 2013-11-24 19:29 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
strace log (955.90 KB, application/x-bzip2)
2011-04-15 00:28 UTC, Vitaliy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitaliy 2011-04-12 05:21:18 UTC
I have some smb/cifs shares mounted via mount -t cifs or via smb4k.
User have full access (write/read/execute) for any files.
How to reproduce:
1) Make any spreadsheet and save it as DBF to SMB/CIFS resource or copy any existing .DBF file fo SMB/CIFS resource
2) Try to open it in LibreOfffice by doubleclick or in any other way.

Error "Can't open file. Can't established connection to file" after selecting character table of DBF will be reported.

OpenSuSE 11.4 with all existing LibreOffice versions on this momnt.

P.S. On opensuse 11.3 I have no this error.
P.P.S. Any other application can open and write DBF files right on smb/cifs shares.
Comment 1 Vitaliy 2011-04-13 01:05:26 UTC
Correcting: After swith to EN locale from russian, error have this look:
"Error. Impossible to connect to the file"
Comment 2 Jan Holesovsky 2011-04-14 14:56:33 UTC
Can you please provide us with a strace?

http://wiki.documentfoundation.org/BugReport#How_to_get_strace_log_.28on_Linux.29

Thank you!
Comment 3 Vitaliy 2011-04-15 00:28:31 UTC
Created attachment 45652 [details]
strace log

strace log of opening dbf file from cifs share in opensuse 11.4
Comment 4 Vitaliy 2011-05-19 06:43:51 UTC
I tried to reinstall all machines from 11.4 to 11.3 with root (/) formatting - new installation with including latest updates for 11.3. The same problem! Openoffice or libreoffice can not open DBF files from smb/cifs resources!  I don't know what to do.. my users need to edit dbf files, but no one tools have in linux to do this but open/libreoffice :(((
Then I try to make a new local user.. and nothing help again..
I am in deadlock...
Comment 5 Vitaliy 2011-05-19 07:10:33 UTC
https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/486443

"nobrl" in cifs mounting options resolve this problem for me!
Comment 6 Alex Thurgood 2011-09-15 06:31:22 UTC
Can not confirm on Mac OSX with SMB Share from OSX Server.


Alex
Comment 7 Björn Michaelsen 2011-12-23 12:05:47 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 Björn Michaelsen 2011-12-23 17:01:03 UTC
needinfo keyword redundant by needinfo status.
Comment 9 Vitaliy 2011-12-23 23:24:52 UTC
(In reply to comment #5)
> https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/486443
> 
> "nobrl" in cifs mounting options resolve this problem for me!

Just have a test period for opensuse 12.1 and have the same problem.
to resolve it use mount options like this:

//10.7.12.11/users	/home/user/mnt/Users	cifs	nobrl,uid=1000,gid=100,username=user,password=user 0 0 

and new bug in 12.1 - internal cifs utilities do not work, so I must install
the kernel devel-s packages, then package 

ftp://download.etersoft.ru/pub/Etersoft/CIFS@Etersoft/5.3.0/SUSE/11.4/etercifs-5.3.0-eter1suse.noarch.rpm 

then make a command from root:

service etercifs build
modprobe cifs
mount -a

and all works fine!
Comment 10 Florian Reisinger 2012-08-14 14:03:38 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 11 Florian Reisinger 2012-08-14 14:04:34 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Florian Reisinger 2012-08-14 14:09:03 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 Florian Reisinger 2012-08-14 14:11:05 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian