Bug 36237 - CONFIGURATION UI Fonts
Summary: CONFIGURATION UI Fonts
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-14 08:38 UTC by abugreporter
Modified: 2013-05-29 11:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description abugreporter 2011-04-14 08:38:05 UTC
Installation of fonts should be a matter of dragging and dropping a font on a running instance of LibreOffice (doesn't matter which application, but at least Writer).

The current way it is done takes 10 minutes or so and requires advanced Linux knowledge. 

This feature is fixed when adding a new font takes 5 seconds. In this state the font is immediately usable.
Comment 1 Björn Michaelsen 2011-12-23 12:05:07 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 sasha.libreoffice 2012-02-27 06:38:24 UTC
@ abugreporter@gmail.com
Please, attach font file. So I can verify if this functionality implemented or not
Comment 3 Florian Reisinger 2012-08-14 14:03:11 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:04:06 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:08:39 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:10:40 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 rtdvrs 2012-08-14 19:38:15 UTC
(In reply to comment #2)
> @ abugreporter@gmail.com
> Please, attach font file. So I can verify if this functionality implemented or
> not
Any font file which isn't already installed would demonstrate this functionality. I suggest you use some searchengine to find one. This does not NEEDINFO in any way. How did you ever even think it would need more information, let alone write a message that this needs more information?
Comment 8 sasha.libreoffice 2012-08-16 07:17:33 UTC
Why not just double click font file? At least in KDE it works.
Comment 9 Roman Eisele 2012-08-22 16:34:57 UTC
> The current way it is done takes 10 minutes or so and requires
> advanced Linux knowledge. 

This is probably a Linux-only issue -- as a MacOS X user, I don’t even understand what’s the problem, and even on Windows, which I hate, installing fonts is not _that_ difficult ... ;-)
Comment 10 Florian Reisinger 2012-08-22 16:46:55 UTC
Hi Roman, all!

(In reply to comment #9)
> > The current way it is done takes 10 minutes or so and requires
> > advanced Linux knowledge. 
> 
> This is probably a Linux-only issue -- as a MacOS X user, I don’t even
> understand what’s the problem, and even on Windows, which I hate, installing
> fonts is not _that_ difficult ... ;-)

No, doubleclicking the font andress install ( without sitting in front of a Windows machine..

BTW: This seems to me like a "notabug". Libreoffice is IMHO not supposed to be a font installer...
Comment 11 abugreporter 2012-08-22 19:24:19 UTC
There are a couple of program to open a font with KDE, but the truth is that no user cares which program it needs. All a user wants is the easiest possible installation of fonts and drag and drop of font files is one such feature which people expect these days.

Everything below is directed at Florian Reisinger:
This is a bug, because an actual user tells you it is a bug, I am not sure how you unilaterally can say that it isn't. If you continue to close this bug, I will just reopen it, for the simple reason that I strongly suspect that you didn't let $NON-TECHNICAL user on Linux try to solve this problem. Somehow I suspect that you didn't do this and as such you are just expressing some lame opinion based on your lack of experience and/or incompetence. 

I am not even opening this bug for myself. I am doing this as a favor for someone else.  

The fix for this problem is very simple: just implement drag and drop as has been done in thousands of programs already around the world. If this is too difficult for you, please just go to some other project (for example, taking care of your garden or something else low-tech, but stop wasting time in technical projects on problems which do have solutions). 

I submitted this project a long time ago. I suspect the reason you are so eager to close this bug is because the rest of the project is full of bugs and that you can then put on your resumé that you fixed some bugs in LibreOffice, while in fact you contributed nothing and only walked in the way of others.  

To the LibreOffice project, I'd suggest to kick Florian Reisinger out of the project as he clearly has a lack of judgement, which is usually fatal to a software project. If he committed anything, I would also strongly urge you to go over his commits, because usually such people cannot write software in the first place. 

If you would rather have that I tell the users in question that LibreOffice developers would like them to take a hike (which is essentially what you are saying now), then I will likely tell them to just reboot the machine, install Word20<hell edition> or whatever it is and tell them to use that. It doesn't matter to me one bit, just don't go crying when you have nobody using your software in a few years.
Comment 12 Urmas 2012-08-23 02:20:19 UTC
First, how's it an application job to install fonts? Which apps do that?

Second, the kind of users which can choose the office software is absolutely useless, as they produce nothing but complains without providing a single cent.
Comment 13 sasha.libreoffice 2012-08-23 06:33:27 UTC
Each user profile of LO has this folder:
~.config/libreoffice/3/user/fonts
may be easy installing of fonts into LO was planned, but not fully implemented
Comment 14 Joel Madero 2013-05-28 15:37:39 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 15 Florian Reisinger 2013-05-28 18:01:45 UTC
Finally close this as NOTOURBUG. LibreOffice is not supposed to install fonts...