Bug 36306 - LibreOffice 3.4 beta1 crash in Letter Wizard
Summary: LibreOffice 3.4 beta1 crash in Letter Wizard
Status: RESOLVED DUPLICATE of bug 37668
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 Beta1
Hardware: All All
: high critical
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-16 12:53 UTC by Andras Timar
Modified: 2011-06-09 02:45 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
crash log (88.18 KB, text/x-log)
2011-04-16 12:53 UTC, Andras Timar
Details
hs_err_pid23354.log (53.00 KB, text/x-log)
2011-05-04 06:18 UTC, Petr Mladek
Details
letter wizard crash stack trace in 3.4 beta3 (112.31 KB, text/plain)
2011-05-04 06:36 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2011-04-16 12:53:51 UTC
Created attachment 45717 [details]
crash log

1. Start LibreOffice
2. File - Wizards - Letter
3. On page 3 of the Letter wizard select a different language. If LibO does not crash immediately, select another language. After 1-2-3 tries, LibO crashes.

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x063cf642, pid=29580, tid=3064198864
#
# JRE version: 6.0_18-b18
# Java VM: OpenJDK Client VM (16.0-b13 mixed mode, sharing linux-x86 )
# Derivative: IcedTea6 1.8.2
# Distribution: Ubuntu 10.04.1 LTS, package 6b18-1.8.2-4ubuntu2
# Problematic frame:
# C  [libvclli.so+0x317642]  _ZN10ServerFont12GetGlyphDataEi+0x78
#
# An error report file with more information is saved as:
# /home/timar/libreoffice-master/install/basis3.4/program/hs_err_pid29580.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
#   https://bugs.launchpad.net/ubuntu/+source/openjdk-6/
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Comment 1 Petr Mladek 2011-05-04 06:18:52 UTC
Created attachment 46323 [details]
hs_err_pid23354.log

There are more problems with the wizard:

1. I am unable to start the wizard at all on SLED10-SP3-i586 with Sun Java 
   1.6.0_21. It crashes immediately. Fridrich saw this also on openSUSE-11.4-i586
   with openJDK. He did not see it with Sun Java. I did not see it on SLED11-
   SP1-x86_64  with Sun Java.

$> /opt/libreoffice/program/soffice
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0xb68d112e, pid=23354, tid=3031570624
#
# JRE version: 6.0_21-b06
# Java VM: Java HotSpot(TM) Client VM (17.0-b16 mixed mode, sharing linux-x86 )
# Problematic frame:
# C  [libvclli.so+0x55112e]  _ZNK5boost16unordered_detail10hash_tableINS0_3mapIi
NS_4hashIiEESt8equal_toIiESaISt4pairIKi9GlyphDataEEEEE4findERS8_+0x1a
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid23354.log
#
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

[error occurred during error reporting , id 0xb]


2. It crashes with Sun Java on both i586 and x86_64 when you do:

     a) open "File/Wizards/Letter"
     b) select "Formal Personal letter" radio button
     c) press "Finish" button

     Result: silent crash
Comment 2 Alex Thurgood 2011-05-04 06:35:47 UTC
COnfirming also on Mac OSX, Apple stack trace attached.


Alex
Comment 3 Alex Thurgood 2011-05-04 06:36:46 UTC
Created attachment 46324 [details]
letter wizard crash stack trace in 3.4 beta3

Letter wizard crash stack trace in 3.4b3
Comment 4 Alex Thurgood 2011-05-04 06:40:41 UTC
I would add that on Mac OSX, the wizard dialog is initially displayed to the left of the main application screen, with the effect that only half of it is displayed, and the user has to move the dialog by hand to the right in order to be able to see it all. There is obviously something wrong with the initial dialog window coordinates.


Alex
Comment 5 Alex Thurgood 2011-05-04 06:50:22 UTC
setting platform to all.
Comment 6 Alex Thurgood 2011-05-04 06:50:57 UTC
shouldn't this be added to the most annoying bugs for 3.4 release ?

Alex
Comment 7 Alex Thurgood 2011-05-04 06:51:53 UTC
Nominating, please remove if inappropriate.

Alex
Comment 8 Alex Thurgood 2011-05-16 03:09:06 UTC
Crash is not reproducible on OOo-dev 3.4.0
Setting regression keyword.


Alex
Comment 9 Rainer Bielefeld Retired 2011-05-24 07:50:36 UTC
NOT reproducible with "LibreOffice 3.4.0RC1  – WIN7  Home Premium  (64bit) German UI [OOO340m1 (Build:11)]", it seems WIN is not affected.
Comment 10 Caolán McNamara 2011-06-01 08:52:23 UTC
There's two different crashes here IMO, the linux-specific glyph-replacement one, and the mac one which looks like a recursive SwGrfNode::SwapGraphic
Comment 11 Jan Holesovsky 2011-06-03 06:19:08 UTC
The crash mentioned in comment 1 as 2):

----- 8< -----
2. It crashes with Sun Java on both i586 and x86_64 when you do:

     a) open "File/Wizards/Letter"
     b) select "Formal Personal letter" radio button
     c) press "Finish" button

     Result: silent crash
----- 8< -----

is unrelated to the original report; I've sent a patch that fixes that for me to the mailing list for review.
Comment 12 Jan Holesovsky 2011-06-03 06:37:33 UTC
Unfortunately I am unable to reproduce the initial problem [neither with Sun, nor with openJDK], so leaving it to somebody who can :-)
Comment 13 Caolán McNamara 2011-06-08 05:00:00 UTC
Looks like bug 37668 is the same as this, woes in ServerFont::GetGlyphData

*** This bug has been marked as a duplicate of bug 37668 ***
Comment 14 Alex Thurgood 2011-06-09 02:19:12 UTC
Hi Caolan,

Closing as dup is all very well, but what about the Mac behaviour, which you felt was linked to a separate problem ? I reopened, changed OS to Mac only.


Alex
Comment 15 Caolán McNamara 2011-06-09 02:41:36 UTC
Ah, don't do that. If multiple bugs are mixed into one bug report it becomes a mess, and becomes unfixable as more and more different things get lumped into it.

So, a comment #0 refers to ServerFont::GetGlyphData, that's a duplicate of bug #37668 and I think we've got the fix for that, or pretty close.

The *other* different recursive recursive SwGrfNode::SwapGraphic fix, well Jan was able to reproduce that, and yesterday we checked in the fix for that separately.

*** This bug has been marked as a duplicate of bug 37668 ***
Comment 16 Alex Thurgood 2011-06-09 02:45:37 UTC
Caolan : OK, Sorry, didn't know about the other fix - have just reverted the platform back again. Good to see that both issues got addressed, thanks :-))

Alex