Bug 36316 - Installation sometimes works, sometimes doesn't
Summary: Installation sometimes works, sometimes doesn't
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
(earliest affected)
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Caolán McNamara
Depends on:
Reported: 2011-04-16 21:16 UTC by Jon Roland
Modified: 2012-01-04 01:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Jon Roland 2011-04-16 21:16:16 UTC
Installed Fedora 14 on two machines. Attempted to install LibreOffice on both. One worked, the other didn't.

On Computer A, did not use the 'yum install *.rpm' method. Instead, in RPMS folder executed as root each rpm, in dependency order. Result was satisfactory. LibreOffice appears in Gnome menu and can also be launched from the command line.

On Computer B, tried using the 'yum install *.rpm' method. Didn't work. Not present to be launched. Found installed using Package Installer. So removed and tried the method that worked for Computer A. That didn't work, either. However, I did find such files as 'soffice', but which launched the menu of apps that self-identified as OpenOffice.org rather than Libreoffice 3 as the other installation did. Removed again, and repeated the one-rpm-at-a-time method. Same result.

It would seem on Computer B the rpms are installing not LibreOffice but a crippled version of OpenOffice.org.

In addition, my attempts to subscribe to the mailing list is being rejected. When I tried to subscribe as jon.roland@constitution.org got

    Diagnostic-Code: smtp; 550 5.7.1 <users+subscribe@libreoffice.org>: Recipient address rejected

So tried another address, jon@jonroland.org. For that one I got back a confirmation message, but when I replied got

    Recipient: <users+confsub-2f6e2c9570adee2c-jon=jonroland.org@libreoffice.org>
    Reason:    5.7.1 <users+confsub-2f6e2c9570adee2c-jon=jonroland.org@libreoffice.org>: Recipient address rejected: Mail appears to be spam or forged and is rejected due to policy.

When I clicked on the IRC link, nothing happened.

At this point I have to wonder whether this is a viable project.
Comment 1 Kohei Yoshida 2011-04-18 12:28:03 UTC
I'll give this to Caolan, and David in CC.  This is a fedora specific issue.

You need to talk to the webmaster about your issue with the mailing list.
Comment 2 Caolán McNamara 2011-04-18 12:51:32 UTC
"It would seem on Computer B the rpms are installing not LibreOffice but a
crippled version of OpenOffice.org."

I super-doubt this. Wouldn't it seem far more likely that you had OpenOffice.org installed before-hand, and that's what you're seeing when you search for soffice, etc.

Massively more likely is that you've now got OpenOffice.org and LibreOffice installed at the same time, where libreoffice is living in /opt/libreoffice and OpenOffice.org in /usr/lib/openoffice.org. 

Assuming that's correct, then the question probably boils down the the desktop-integration rpms that install the .desktop files etc to put it into the menus.

Was there any messages from the install about rpms conflicts or anything of that nature ?
Comment 3 Jon Roland 2011-04-18 13:15:08 UTC
No. OpenOffice was absolutely not installed previously. It was a fresh install of Fedora 14 which does not come with OO. It was not only not in the packages shown installed, but I did a check using the 'which" command from the shell. The files did not appear until I ran the rpms in the RPMS folder, and they are OO files, not LO files. 

The only difference between the two installations is that in the second I had enabled 'Fedora 14 - i386 - Test Updates' as a source. But I tried disabling it and repeated the installation process. Same result.

As for contacting the webmaster of the email lists, I don't find contact information for him or her. 

I have given up on LibreOffice and installed OpenOffice. It's installer works. When I hear there is a comparable installer for LibreOffice I'll switch.
Comment 4 Caolán McNamara 2011-04-18 13:46:59 UTC
It'll be the default in F-15 FWIW
Comment 5 Jon Roland 2011-04-18 14:14:29 UTC
After doing the installation on Computer B, both package managers,
gpk-application and Synaptic (front-end for apt-get) showed some but not all OO
packages installed, and no LO packages. Indeed, the packages appeared one at a
time as I ran each rpm. I thought LO was somehow identifying itself to the
package managers as OO, but when I tried to run them I got 'OpenOffice 3.0' and
not 'LibreOffice 3.0'.

When I removed the packages it was OO packages I removed, and the files did
indeed disappear. And came back the next time I ran those rpms. Somehow they
are getting their files from a different source.
Comment 6 Caolán McNamara 2011-04-19 01:16:57 UTC
You originally said fedora, now you're talking about apt-get and Synaptic which aren't the usual Fedora tools to install packages. 

If you're on fedora do...

rpm -qa | grep openoffice
rpm -qa | grep libreoffice

and paste the results in here
Comment 7 David Tardon 2011-04-19 05:57:11 UTC
What rpm files are in the dir RPMS on both A and B? And how did you get them? Downloaded them from a website (which one?), built from sources,...?

Btw, for direct installing of rpms by yum one has to use localinstall command, e.g.,

yum localinstall libreoffice-*.rpm
Comment 8 Petr Mladek 2011-05-12 06:30:06 UTC
The installation works in general, so this problems is caused by a strange scenario => reducing severity

Jon, please provide the information asked in the comment #6 and comment #7. We could not move forward without it.
Comment 9 Jon Roland 2011-05-25 05:52:03 UTC
Okay, I tried to install on yet another machine, after upgrading Fedora 12 to Fedora 14. I wanted to run the tests requested so we could determine what might be the problem. But, with the same setup as before, minimal package sources, when I tried to run the rpm scripts from the RPMS folder, each would go through the analysis, but when it came to actually downloading the package files, indicated by the progress bar of hash characters, they hung. None of them actually downloaded anything. Which means I also don't have any logs that might be helpful for diagnosis.

We definitely need a proper installer like the one used for OO, which always seems to work. Is there some reason the LO project can't just use that one with a few changes? Is it proprietary?
Comment 10 Caolán McNamara 2011-05-25 06:33:30 UTC
"when it came to actually downloading the package files indicated by the progress bar of hash characters, they hung. None of them actually downloaded anything. Which means I also don't have any logs that might be helpful for diagnosis."

?. Please give an exact step-by-step as to what you are doing. What is doing this downloading that hangs ?
Comment 11 Jon Roland 2011-05-25 07:23:39 UTC
In response to #10, I did exactly what I said I did in #1, according to the instructions:

# yum install *.rpm

for each rpm in the RPMS folder that one gets after extracting the installation file LibO_3.3.2_Linux_x86_install-rpm_en-US.tar.gz  from the LO website. When one does that one gets a series of message lines, that ultimately get to the point where files are downloaded, with a progress bar of ###### for each file. I never got that, after trying many of the rpms, starting with the base one, libreoffice3-ure-1.7.0-202.i586.rpm . I interpret that as a failure to find the file to be downloaded, even though I was online and other access was working.
Comment 12 Caolán McNamara 2011-05-25 07:38:09 UTC
Ah, no. That's not downloading anything, its already downloaded, presumably that's yum attempting to show installation progress.

If you use yum, try yum --verbose localinstall *.rpm and paste the output here.

(rpm --install -v *.rpm is an alternative)