Bug 36322 - copy and paste a heading text
Summary: copy and paste a heading text
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-17 05:00 UTC by Jochen
Modified: 2016-03-07 15:01 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jochen 2011-04-17 05:00:46 UTC
If copying text of an heading/title and pasting as unformatted text (german menue: "Bearbeiten" -> "Inhalte einfügen..." -> Auswahl "Unformatierter Text") chapter number is inserted also - ie front of the pasted text.

The chapter number must be manually deleted.

LibreOffice 3.3.2 OOO330m19 (Build:202) tag libreoffice-3.3.2.2
OS: Windows 7 Professional (64 bit)
Comment 1 Regina Henschel 2011-04-17 05:37:58 UTC
Corresponding OOo bug is http://openoffice.org/bugzilla/show_bug.cgi?id=63827
Comment 2 Kohei Yoshida 2011-04-18 12:49:39 UTC
Steps to reproduce:

1. In a new document, type several paragraphs of text, and apply numbering.
2. Move down a bit to an area where no numbering is applied.
3. Select a part of text from where the numbering is applied, then paste-special as unformatted text into the unnumbered area.

Then the pasted text gets prefixed with the number.  Normal paste via Ctrl-V doesn't do this.

I'll give this to Cedric.
Comment 3 Jochen 2011-04-18 13:16:16 UTC
Hi Kohei,

Two questions/comments.

1) "the pasted text gets prefixed with the number".
Example:
paragraphs-text is "2.3.2) blabla"
Copy "blabla"
Pasted text is "2.3.2) blabla"
I expect "blabla"
IMHO a bug?! Your opinion also?
Some people on german discuss-ML believe this is normal respectively correct.

2) "Normal paste via Ctrl-V doesn't do this"
IMHO normal paste via Ctrl-V causes the problem also. What do You mean with "doesn't do this"?
Comment 4 Harald Koester 2012-08-01 14:27:47 UTC
See also bug 49076.
Comment 5 manj_k 2013-02-12 23:17:39 UTC
(In reply to comment #1)
> Corresponding OOo bug is http://openoffice.org/bugzilla/show_bug.cgi?id=63827

Now: https://issues.apache.org/ooo/show_bug.cgi?id=63827
(Added to "See Also")
Comment 6 Michael Stahl (CIB) 2013-04-23 13:58:06 UTC
this is not a bug but a feature.

if you copy the whole heading you also want the chapter numbering, because otherwise the only alternative is to type in the chapter numbering manually in the target application, which is a lot more annoying than deleting it in the rare case where you don't want it.
Comment 7 Jochen 2013-04-25 11:20:45 UTC
Hi *,

I propose the "bug" as an enhancement.
Comment 8 Joel Madero 2014-11-04 03:18:52 UTC
Never confirmed by QA team - moving to UNCONFIRMED.
Comment 9 tommy27 2014-12-25 06:55:59 UTC
(In reply to Michael Stahl from comment #6)
> this is not a bug but a feature.
> 
> if you copy the whole heading you also want the chapter numbering, because
> otherwise the only alternative is to type in the chapter numbering manually
> in the target application, which is a lot more annoying than deleting it in
> the rare case where you don't want it.

I think we should close this as NOTABUG
Micheal Stahl is an expert LibO Writer developer and I agree with his opinion.