Download it now!
Bug 36427 - A MS XML 2003 file cannot be saved in Calc
Summary: A MS XML 2003 file cannot be saved in Calc
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-20 09:07 UTC by soshial
Modified: 2015-06-19 13:48 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
a file that can be edited but not changed (20.37 KB, text/xml)
2011-04-21 05:31 UTC, soshial
Details
It cannot be saved as Excel 2003 XML. (452.50 KB, application/x-msexcel)
2011-11-10 07:15 UTC, Scott M. Sanders
Details
soshial's file saved under Linux using v3304 through v4132. (33.19 KB, application/zip)
2013-12-15 11:35 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soshial 2011-04-20 09:07:26 UTC
LibreOffice says:

Error saving the document ...
Write error
The file could not be written.
Comment 1 soshial 2011-04-21 05:06:26 UTC
Has been fixed in LibreOffice 3.3.2
Comment 2 soshial 2011-04-21 05:31:25 UTC
Created attachment 45913 [details]
a file that can be edited but not changed
Comment 3 Scott M. Sanders 2011-07-14 10:24:39 UTC
I am getting this in 3.4.1 with my data.
Comment 4 Valek Filippov 2011-11-10 07:09:22 UTC
Works fine for me (Linux, LO 3.4.3).
Comment 5 Scott M. Sanders 2011-11-10 07:15:26 UTC
Created attachment 53371 [details]
It cannot be saved as Excel 2003 XML.

It still fails for me. I attached an example.
Comment 6 Björn Michaelsen 2011-12-23 12:04:28 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 Scott M. Sanders 2011-12-30 07:37:12 UTC
This persists in 3.5.0beta2.
Comment 8 Valek Filippov 2012-02-06 04:31:12 UTC
(In reply to comment #5)
> Created attachment 53371 [details]
> It cannot be saved as Excel 2003 XML.
> 
> It still fails for me. I attached an example.

It works fine for me with 3.4
Comment 9 soshial 2012-02-07 10:40:43 UTC
LO 3.5.0rc3 on WinXP SP3 32bit

I open the file 452.50 KB, type some new info and try to save as "Microsoft Excel 2003 XML (.xml)".

After 45 seconds Calc says:
"Error saving the document ...:
Write Error.
The file could not be written."
Comment 10 Greg 2012-03-09 14:09:25 UTC
I too am experiencing this bug. And probably the related long read times of 2003 XML, hang and sometimes crash of XML 2003 spreadsheet.

It never crashes on load of an EXCEL generated spreadsheet. It can save the Excel generated spreadsheet once. But exit OO or LO and then re-load OO or LO calc and try to read the oo written file:
a) sometimes, hangs and crashes
b) sometimes, does not. But when does not, can't write the file XML 2003. Get the long wait then file IO write error, as previously described. Can write the file as ODT, and other formats.

Seems the 2003 XML file by some seems out-dated or obsolete. Why we need it:
1) it is simple to parse using XML tools. If a very 'flat' low maintenance spreadsheet format. So the data in the file is accessible easily be simple easy to write tools.

2) is the only format that meets the crieria a), and is common with MS EXCEL.
3) the new formats, are quite a bit more work to parse, write tools to read the data in the files.

Is there any progress being made on this issue. It seems to have been a problem since after OO 2.2, I think I saw a report of these bugs as far back as 2008.
And a long line of disgruntled attempts to use it, and of course the format will fall in disuse if it dont work. Please, is there a patched filter we can use?
Comment 11 Greg 2012-03-09 14:10:58 UTC
Both bugs found and verified.
For got to mention. 
Is on 3.3 Linux OO. 
Is on LO 3.5 Win 64.

+G
Comment 12 Greg 2012-03-09 14:11:54 UTC
Reported bug on 3.5 beta, also on release
Comment 13 Nicolas Toniazzi 2013-05-03 08:00:48 UTC
Still here in 4.0.2.2 under Linux x86
Comment 14 ign_christian 2013-05-20 05:23:49 UTC
I try to summarize, seems that 2 issues here:
1. attachment 45913 [details] from soshial -> XML file can't be changed & saved
2. attachment 53371 [details] from Scott -> XLS file can't be saved to Excel 2003 XML

Don't know should it be splitted to 2 bugs?

Confirm that 2 issues occured while I'm testing with LO 4.0.3.3 (Win7 32bit)

Set Version to: 3.4.1 -> oldest release based on comment 3
Set Platform to: All -> known problems on Windos & Linux  32 & 64bit
Comment 15 Owen Genat (retired) 2013-12-15 11:23:02 UTC
(In reply to comment #14)
> I try to summarize, seems that 2 issues here:
> 1. attachment 45913 [details] from soshial -> XML file can't be changed &
> saved
> 2. attachment 53371 [details] from Scott -> XLS file can't be saved to Excel
> 2003 XML
> 
> Don't know should it be splitted to 2 bugs?

To be honest this bug appears to have become a mess. If LO is started from the terminal the messages output there give a clearer indication of which attachment exhibits which problem. The first attachment does not appear to exhibit a problem under Ubuntu 10.04 x86_64 running: 

- v3.3.0.4 OOO330m19 Build: 6
- v3.4.6.2 OOO340m1 Build: 602
- v3.5.7.2 Build ID: 3215f89-f603614-ab984f2-7348103-1225a5b
- v3.6.7.2 Build ID: e183d5b
- v4.0.6.2 Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24
- v4.1.3.2 Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a

... at least in terms of opening, modifying the contents (e.g., typing "a" into A1), and re-saving to the Excel 2003 XML format. v4.0.6.2 does take a long time to re-load the saved document. v4.1.3.2 throws a "General input/output error" on re-load after save. This is likely a separate issue. 

Unfortunately though this problem of not saving changes was initially reported against v3.3.0 release and gradually increased over time by several people (possibly for several different issues), so if this attachment does have a problem it may be Windows-specific and relate to a quite early version. I would set the Platform back to Windows and Version back to 3.3.0 accordingly. The remarks in comment #11 and comment #13 need to clearly indicate which attachment is being used.

The second attachment exhibits the problem described in bug 52035 i.e., infinite template recursion.
Comment 16 Owen Genat (retired) 2013-12-15 11:35:06 UTC
Created attachment 90798 [details]
soshial's file saved under Linux using v3304 through v4132.
Comment 17 retired 2013-12-15 12:15:57 UTC
A mess indeed but reproducible for me on OSX 10.9 LO Version: 4.3.0.0.alpha0+
Build ID: b578d23d3131f30d775e07baa6fa26e247ea999d
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-12-13_00:32:50

* open the file "it cannot be saved as excel 2003 xml"
* enter some content
* save as
* 2003 XML

LO crashes: http://pastebin.com/qjzkFAU3

So all OS seems correct.
Comment 18 Owen Genat (retired) 2013-12-16 12:07:47 UTC
(In reply to comment #17)
> A mess indeed but reproducible for me on OSX 10.9 LO Version: 4.3.0.0.alpha0+
> Build ID: b578d23d3131f30d775e07baa6fa26e247ea999d
> ...
> LO crashes: http://pastebin.com/qjzkFAU3

Well it is certainly /a/ problem, although the original reports did not indicate v3.3 thru v3.5.0rc3 crashing. Trying to determine if it is the same issue will be a challenge. Disconcerting to see a more serious problem in the alpha releases, even for a marginally used format.
Comment 19 retired 2013-12-16 12:47:21 UTC
hehe, yes I never understood what XML is used for in the area of spreadsheets but that maybe due to my ignorance or little knowledge in that area. Never used that myself or saw any use. Owen, could you escalate this to the dev chan?
Comment 20 Owen Genat (retired) 2014-09-29 12:40:18 UTC
(In reply to comment #15)
> v4.1.3.2 throws a "General input/output error" on re-load after save. 
> This is likely a separate issue. 

Small update on this. Re-tested attachment 45913 [details] under GNU/Linux using:

v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
v4.2.6.3 Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21
v4.3.2.2 Build ID: edfb5295ba211bd31ad47d0bad0118690f76407d
v4.4.0.0.alpha0+ Build ID: df73f4115cfe4d07e4159adf087571687eb173ec TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-09-25_23:06:16

v4.1 appears to have suffered a regression in handling the OPC 2003 XML file format, as the version listed eventually becomes unresponsive. v4.2-4.4 all handle opening, updating, saving, closing, and re-opening the updated file as expected.

> The second attachment exhibits the problem described in bug 52035 i.e.,
> infinite template recursion.

(In reply to comment #17)
> * open the file "it cannot be saved as excel 2003 xml"
> * enter some content
> * save as
> * 2003 XML
> 
> LO crashes: http://pastebin.com/qjzkFAU3

I have just realised that this is the attachment I mentioned above as being covered under bug 52035. The example in this report may be XLS->XML and in the corresponding report ODS->XML but it is the XSLT filter that seems at fault. foss, if you can confirm you get the same error for the attachment in that bug, I think we can RESOLVE this one as WORKSFORME. Thanks.
Comment 21 Timur 2015-06-19 13:48:52 UTC
Per last comment attachment from soshial works already from LO 4.2, and Scott's is another issue, probably already reported as bug 52035.