Bug 36445 - UI Trouble with Mac double-arrow scrollbar option
Summary: UI Trouble with Mac double-arrow scrollbar option
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-04-20 17:51 UTC by Dave Yost
Modified: 2012-08-31 10:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
TinkerTool screen shot (157.90 KB, image/png)
2011-04-20 17:52 UTC, Dave Yost
Details
screen shot showing double arrows at both ends of scroll bar (66.22 KB, image/png)
2011-04-20 17:53 UTC, Dave Yost
Details
Movie showing the bug (256.82 KB, video/quicktime)
2011-04-20 17:58 UTC, Dave Yost
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Yost 2011-04-20 17:51:12 UTC
You can use a 3rd-party app such as TinkerTool to enable an undocumented OS UI option that puts arrows for both directions at both ends of scrollbars. Using ASCII art, I will attempt to show what I'm talking about. At each end of the scroll bar there are two arrows,
  < > -------[============]---------- < >
instead of one
  < ---------[============]------------ >

In OpenOffice Writer, these don't work correctly. If you click on the innermost
arrow at each end, it is as if you clicked in the scrollbar area.

This hidden option has been in Mac OS X for many years, and there are many apps that will enable the option. TinkerTool is just one such tweaker app.

See the attachments to follow.
Comment 1 Dave Yost 2011-04-20 17:52:20 UTC
Created attachment 45892 [details]
TinkerTool screen shot

In TinkerTool, select the General panel. Then set
"Place scroll arrows" to "together at both ends".
Comment 2 Dave Yost 2011-04-20 17:53:38 UTC
Created attachment 45893 [details]
screen shot showing double arrows at both ends of scroll bar

Screen shot of what the scroll bar looks like with the option set to "Place scroll arrows" "together at both ends".
Comment 3 Dave Yost 2011-04-20 17:58:19 UTC
Created attachment 45894 [details]
Movie showing the bug

This movie goes by really fast, so maybe you should step through it slowly.

I click a few times on the down control, and the window scrolls a little bit each time. So far, so good. Then I click on the up control, and it scrolls all the way in the other direction. The reason this happens is that although the up control is displaying, when I click there, it is as if I clicked in the end of the scroll bar area, which on the Mac (unless you set an option otherwise) scrolls to there, i.e. all the way to the end.
Comment 4 Björn Michaelsen 2011-12-23 12:04:43 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 sasha.libreoffice 2012-02-27 06:46:24 UTC
@ Dave Yost
Libre Office renders it's own interface. No matter what option of OS selected. Let ask expert about this.
@ Caolan
What You think about this?
Comment 6 Caolán McNamara 2012-02-27 07:32:08 UTC
yeah, someone would have to implement the emulation in vcl/aqua/source/gdi/salnativewidgets.cxx 

this is kind of obscure stuff though, some mac hacker would have to take this task up, probably not too hard to implement, but not something I'll personally be implementing.
Comment 7 sasha.libreoffice 2012-02-27 07:34:59 UTC
Easy hack for Mac?
Comment 8 Caolán McNamara 2012-02-27 07:46:18 UTC
kind of need a mac hacker to hazard a guess really
Comment 9 Thorsten Behrens (allotropia) 2012-04-12 03:52:37 UTC
(In reply to comment #0)
> In OpenOffice Writer, these don't work correctly. If you click on the innermost
> arrow at each end, it is as if you clicked in the scrollbar area.
> 
Incidentally - Dave, can you check if Firefox handles this correctly?
Comment 10 Florian Reisinger 2012-08-14 13:58:52 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 11 Florian Reisinger 2012-08-14 14:00:06 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 12 Florian Reisinger 2012-08-14 14:04:46 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 13 Florian Reisinger 2012-08-14 14:06:52 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 14 Dave Yost 2012-08-14 18:20:11 UTC
Can't try it in Firefox because the latest os (10.8) doesn't have arrows at the ends of scrollbars anymore.
Comment 15 Florian Reisinger 2012-08-16 11:29:44 UTC
Okay, anyway I will change it to NOTOURBUG