Download it now!
Bug 36451 - Localisation breakage in 3.4 beta2
Summary: Localisation breakage in 3.4 beta2
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.0 Beta2
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 36450 36477 36657 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-21 00:00 UTC by Volker Merschmann
Modified: 2011-04-28 06:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Mixed Languages (63.34 KB, image/png)
2011-04-21 00:00 UTC, Volker Merschmann
Details
Missing selections (222.85 KB, application/x-download)
2011-04-22 03:26 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Volker Merschmann 2011-04-21 00:00:36 UTC
Created attachment 45905 [details]
Mixed Languages

Installing the nightly build 20110420 on Windows XP Pro

The installer starts in english. Systems language (german) has been added to the "Additional Languagepacks" selector but is not defaulted.

UI starts in mixed language, mostly english, although setting is correct. (see screenshot)
Changing the setting to english-restarting-german-restarting does not help.

Tried with old userprofile from 3.3.2 and without, does not matter.
Comment 1 vitriol 2011-04-21 00:11:03 UTC
Same behavior with Italian language. See Bug 36450.
Comment 2 Don't use this account, use tml@iki.fi 2011-04-21 00:17:15 UTC
This is surely caused by the problem in localisation processing in the 3.4 builds. Lots of strings appear not translated. We know this and we know how to fix it already. We will get a shitload of duplicates for this problem, too, I am sure. I wish we could put a note on the download page about known problems with the "nightly" (haha) build and beta2, to avoid pointless duplicated bug reports. But maybe that would be considered bad publicity?
Comment 3 Don't use this account, use tml@iki.fi 2011-04-21 00:18:50 UTC
*** Bug 36450 has been marked as a duplicate of this bug. ***
Comment 4 Volker Merschmann 2011-04-21 02:36:11 UTC
Adjusted Version

Beta2 should not be shipped with this bug, imho
Comment 5 Volker Merschmann 2011-04-21 02:36:51 UTC
sry
Comment 6 Don't use this account, use tml@iki.fi 2011-04-22 02:40:04 UTC
*** Bug 36477 has been marked as a duplicate of this bug. ***
Comment 7 Rainer Bielefeld Retired 2011-04-22 03:26:34 UTC
Created attachment 45940 [details]
Missing selections

@Tor Lillqvist:
Might be we have more problems than only untranslated strings. For me 2 of my installed UI languages are missing in the UI language picker, I believe that's a separate bug.
Comment 8 Don't use this account, use tml@iki.fi 2011-04-22 03:36:09 UTC
Aren't you confusing help localisations and UI languages? The "Help Pack" thingies you see as separated installed products (or "programs") are a different thing, not related to the UI languages you select as features when installing the single LibreOffice product.
Comment 9 Rainer Bielefeld Retired 2011-04-22 03:44:56 UTC
Definitively a blocker
Comment 10 Rainer Bielefeld Retired 2011-04-22 03:58:37 UTC
@Tor:
(In reply to comment #8)
> Aren't you confusing help localisations and UI languages? The "Help Pack"
> thingies 

Hi, you are right, of course! But those are the languages I selected in the language picker during installation for LibO. So the additional problem does exist, but my proof was wrong.
Comment 11 Rainer Bielefeld Retired 2011-04-22 05:55:58 UTC
Comment on attachment 45940 [details]
Missing selections

Wrong proof
Comment 12 Rainer Bielefeld Retired 2011-04-22 06:00:34 UTC
Repair function healed my additional problem "installed UI languages not available. During the repair process I did not see English and Spanish, but selection and repair process added the 2 languages to my language picker. I will not install Beta2 on an additional CP, so currently I can not follow that effect up. If I see evidence that that's a real problem i will file a different pub report (if no other one has been faster).
Comment 13 Andras Timar 2011-04-26 05:12:43 UTC
It was a path problem on Windows, because Windows applications could not follow Cygwin symlinks.

Fixed by this commit:
http://cgit.freedesktop.org/libreoffice/bootstrap/commit/?h=libreoffice-3-4&id=8c5bd2ea4055610478bc700142fb16376d2cef15
Comment 14 Don't use this account, use tml@iki.fi 2011-04-28 06:52:06 UTC
*** Bug 36657 has been marked as a duplicate of this bug. ***