Bug Hunting Session
Bug 36615 - EDITING: Some words are converted to hyperlinks
Summary: EDITING: Some words are converted to hyperlinks
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86 (IA32) Windows (All)
: high blocker
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords: regression
: 36640 36941 37194 37777 (view as bug list)
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-04-26 11:48 UTC by Michael Nunneley
Modified: 2011-08-16 14:02 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Nunneley 2011-04-26 11:48:22 UTC
I am using Writer and I find that when I type the work "sick" followed by a "." or a"," then the space bar, the word sick and following becomes underlined and I cannot turn it off. I repeated this several times.

I am using windows 7 home premium 64-bit with 5gb Ram, Nvidia 9400GT on an HP Pavilion.
Comment 1 vitriol 2011-04-26 12:09:24 UTC
I confirm this behavior. Is wrongly detected as hyperlink.
Comment 2 vitriol 2011-04-26 12:10:30 UTC
Regression. It works fine on 3.3.2
Comment 3 Zack 2011-04-27 14:55:12 UTC
Confirmed on Windows 7.
Comment 4 Zack 2011-04-27 15:20:35 UTC
Type "A slot machine" and it does it as well. Adding it as an annoying bug for the 3.4 release because this is an unacceptable bug to have in a release.
Comment 5 Zack 2011-04-27 15:49:34 UTC
*** Bug 36640 has been marked as a duplicate of this bug. ***
Comment 6 Petr Mladek 2011-04-28 03:34:23 UTC
I see it on Linux as well. It is quite annoying.

Cedric, would you have time to look at it?
Comment 7 DV 2011-04-29 05:11:16 UTC
Still presente in 3.4 Beta 3. 

Just type repeatedly "seal" to reproduce.
Comment 8 Rainer Bielefeld Retired 2011-04-30 00:42:53 UTC
Modified Status due to facts
Modified OS due to Comment 6

"Bug 36640 - Involuntary conversion of word to hyperlink" contains lots of examples
Comment 9 Florian Heckl 2011-04-30 13:16:19 UTC
I can add that it happened for me also with Beta 2 already on Mac OS X (x86, not -64).
Comment 10 Duncan Lithgow 2011-05-03 01:57:09 UTC
Same behaviour on Win 7 / 64bit with LO3.4 beat3 when I type

skal 

followed by a space (it's a Danish word). It becomes an smb:/// link
Comment 11 manj_k 2011-05-07 12:27:01 UTC
*** Bug 36941 has been marked as a duplicate of this bug. ***
Comment 12 manj_k 2011-05-07 13:18:39 UTC
I have changed the wrong and misdirecting "Incorrect words" in the summary to "Some words".
That bug doesn't depend on AutoSpellcheck (ASP) or any language. Words with language attribute "None" or with deactivated ASP are also affected.
Comment 13 NX 2011-05-09 00:02:37 UTC
Still not fixed in LibO 3.4 beta 4
Comment 14 Rainer Bielefeld Retired 2011-05-09 00:16:08 UTC
(In reply to comment #13)
> Still not fixed in LibO 3.4 beta 4

Of course not, here is no comment concerning a fix and / or integration! 

<http://wiki.documentfoundation.org/BugReport_Details#Version>
Comment 15 Claude 2011-05-13 20:49:00 UTC
Confirmed in 3.4.beta 5 writing in spanish at least two words
sido
sean 
as soon as the space after the two words is entered, an hyperlink format is associated:
smb:///  for the first combination of letters
slot: for the second.
It doesn´t happen if the words are at the beginning of the line.

Just my two cents....
Claude
Comment 16 vitriol 2011-05-14 04:12:08 UTC
*** Bug 37194 has been marked as a duplicate of this bug. ***
Comment 17 Pascal 2011-05-14 04:21:16 UTC
it also links german sind
Comment 18 DV 2011-05-15 11:05:32 UTC
(In reply to comment #17)
> it also links german sind

Apparently, it simply doesn't matter what the language is. As I had indicated in duplicated bug 36640, several random combinations of "s" + "i" or "e" trigger the conversion of the word into a hyperlink. 

Examples: "seen", "seem", "seam", "sick", "sion", "sean", "seon", "seol", "siam", "seal","sial".  

Because it happens in several languages, with both existing and non-existing words it doesn't seem to be related with spellcheck or AutoCorrect.
Comment 19 k-j 2011-05-19 02:56:10 UTC
It is the same in RC1 (WIN XP 32bit SP3 German).

It is a nogo-version for German if the word "sind" (first and third person singular of the word "to be") will be hypermarked every time.

No normal user can kandle and accept such a behaviour.
Comment 20 Christian Lohmaier 2011-05-19 04:49:45 UTC
deserves blocker severity - you cannot tell uses to constantly hit <ctrl>+z/undo when the wrong hyperlink-detection happens - also LO seems to freeze (100%CPU) or crash because of this (crash/freete not 100% reproducible, but by just stupididly type the same word over and over again, if it is turned into hyperlink, open a new paragraph, repeat, at some point it will crash instead of turning to hyperlink)
Comment 21 Cédric Bosdonnat 2011-05-19 08:14:52 UTC
Fixed in 3-4 branch. Still waiting for 2 reviews before pushing in 3-4-0 branch.

http://cgit.freedesktop.org/libreoffice/libs-gui/commit/?h=libreoffice-3-4&id=30428e1b7088df9b61a18c9b47557669cb542622
Comment 22 Michael Meeks 2011-05-20 02:17:08 UTC
pushed to 3.4.0 after triple review,
Comment 23 manj_k 2011-05-24 02:03:41 UTC
Tested with 'nightly' LibO 3.4 v2011-05-23 [on WinXP]
(libreoffice-3-4~2011-05-23_13.32.39_LibO_3.4.0rc1_Win_x86_install_multi.exe):

Not any longer conversion into hyperlink for:
seen, seem, seam, sick, sion, sean, seon, seol, siam, seal, sial, sind, slot, skal, [...] skol.
Comment 24 DV 2011-05-24 05:12:01 UTC
(In reply to comment #23)
> Tested with 'nightly' LibO 3.4 v2011-05-23 [on WinXP]
> (libreoffice-3-4~2011-05-23_13.32.39_LibO_3.4.0rc1_Win_x86_install_multi.exe):
> 
> Not any longer conversion into hyperlink for:
> seen, seem, seam, sick, sion, sean, seon, seol, siam, seal, sial, sind, slot,
> skal, [...] skol.

Confirm fix on WinXp. Many thanks to the developers!
Comment 25 NX 2011-05-25 05:18:40 UTC
Also German Windows-Version works. Problem fixed. Expression "sind" won't be converted to hyperlinks anymore. Thanks to all involved!
Comment 26 vitriol 2011-05-31 00:08:49 UTC
*** Bug 37777 has been marked as a duplicate of this bug. ***
Comment 27 John Farrar 2011-05-31 00:33:40 UTC
(In reply to comment #26)
> *** Bug 37777 has been marked as a duplicate of this bug. ***

Using 3.4.0 000340m1 (Build 11)
Comment 28 vitriol 2011-05-31 00:40:42 UTC
(In reply to comment #27)

> Using 3.4.0 000340m1 (Build 11)

I think that is RC1. Please, try RC2.
Comment 29 John Farrar 2011-05-31 02:55:12 UTC
Whoops, you are correct!  Sorry to waste your time.