Download it now!
Bug 36748 - Zero results do not appear when workbook is opened.
Summary: Zero results do not appear when workbook is opened.
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium minor
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-01 09:58 UTC by cassio.neri
Modified: 2013-11-15 11:11 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Zero results don't appear when this workbook is opened. (6.71 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-05-01 09:58 UTC, cassio.neri
Details
Patch to fix bug 36748. (1.23 KB, patch)
2011-05-01 10:34 UTC, cassio.neri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cassio.neri 2011-05-01 09:58:02 UTC
Created attachment 46227 [details]
Zero results don't appear when this workbook is opened.

When you save a workbook zero values are not saved if they are formula results.

This is not a big issue when "Tools / Cell Contents / AutoCalculate" is on since, when opening the workbook, formulas are recalculated and their results are shown.

However, if "AutoCalculate" is off, then recalculation doesn't happen and zero results are left blank (even if "Tools / Options / LibreOffice Calc / View / Zero values" is checked).

In attachment an example workbook. A zero appears on A1 because it's not a formula. Zeros should appear in cells A2, A3, A4 and A5 but they don't. Press F9 to force calculation and you will see all zero values.

Additional remarks:

1) I've first noticed this bug in OOo 3.3.0 and I reported it in OOo's issue tracker (106135). It has been confirmed there.
2) The same problem happens on Windows Vista x86-64.
Comment 1 cassio.neri 2011-05-01 10:34:22 UTC
Created attachment 46228 [details]
Patch to fix bug 36748.

Also sent to the dev mailing list:
http://lists.freedesktop.org/archives/libreoffice/2011-May/011263.html

Released under LGPLv3+ / MPL.
Comment 2 Kohei Yoshida 2011-05-02 18:03:46 UTC
Pretty safe fix.  I pushed it to the 3.4 branch.  Thanks a lot.

http://cgit.freedesktop.org/libreoffice/calc/commit/?h=libreoffice-3-4&id=be929acaaa752c3b8754bb0f4ba7013ea44c1595