Bug 36819 - Use transparency to make disabled/hidden slides more obvious
Summary: Use transparency to make disabled/hidden slides more obvious
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-03 20:11 UTC by Jean-François Fortin Tam
Modified: 2011-12-25 17:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (329.21 KB, image/png)
2011-05-03 20:11 UTC, Jean-François Fortin Tam
Details
mockup (438.64 KB, image/png)
2011-05-03 20:13 UTC, Jean-François Fortin Tam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2011-05-03 20:11:04 UTC
Created attachment 46304 [details]
screenshot

When right-clicking a slide in the sidebar or the slide sorter, you can hide/unhide (enable/disable) individual slides to be shown during the presentation.

The problem is that their hidden state is not obvious enough: the only visual indication you have is that there is a diagonal line going through the small "slide number" box.

A better way to indicate the disabled/hidden state of slides, as well as ensure that they do not needlessly clutter the view, would be to make them 50% transparent.

Attached is a screenshot of how it currently looks like; try spotting, in a split-second, which slides are disabled or not when you have dozens of them!
Comment 1 Jean-François Fortin Tam 2011-05-03 20:13:22 UTC
Created attachment 46305 [details]
mockup
Comment 2 Rainer Bielefeld Retired 2011-05-03 22:37:29 UTC
Nice idea, but IMHO a diagonal red strike through bar might do the same with less consumption of resources
Comment 3 Jean-François Fortin Tam 2011-05-04 06:29:44 UTC
Doesn't it use hardware acceleration/compositing for transparency anyway? Perhaps it could do one or another depending on the availability of HW accel. But yes, at the end of the day, a big diagonal strikethrough could do the job (just a bit less elegantly).
Comment 4 Björn Michaelsen 2011-12-23 12:05:33 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Jean-François Fortin Tam 2011-12-25 17:02:06 UTC
This was fixed in 3.4.