Bug Hunting Session
Bug 36846 - Setup TDF EXTENSION infrastructure
Summary: Setup TDF EXTENSION infrastructure
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: All All
: high enhancement
Assignee: Thorsten Behrens (CIB)
URL: http://libreplanet.org/wiki/Group:Ope...
Whiteboard:
Keywords:
: 39624 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-04 09:24 UTC by Rainer Bielefeld Retired
Modified: 2011-12-23 13:25 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-05-04 09:24:28 UTC
It seems OOo moved download pages, so links to OOo download site are broken now. I tested PDF-Import, Alba, Afrikaans spell checker, CADOO.o and AddPics,  all broken ("Document does not contain data")

Some others (Barcode, AutoText - EmotiKons, ...) work fine.
Comment 1 Rainer Bielefeld Retired 2011-05-04 09:53:20 UTC
BTW, we should have our own LibO Estensions download site May be a WIKI page with links to Source Forge ...)
Comment 2 Muthu 2011-05-05 01:50:08 UTC
One for petr? -> requirements
Comment 3 Petr Mladek 2011-05-06 08:09:29 UTC
I think that we have some redirections on the FDO servers to OOo site.
Thorsten, do you know who could modify them?

BTW: Rainer, do you know if the site was moved or removed? Do you know about any new location?
Comment 4 Rainer Bielefeld Retired 2011-05-06 10:34:50 UTC
It seems some other moved in between, I don't know anything concerning intentions or technical background.

Currently OOo Extensions project can't be reached at all.

It seems they are modifying the infrastructure, I fone 2 very different download sites:
"old fashion style":
<http://extensions.services.openoffice.org/project/>
Never seen before:
<http://openoffice.org/projects/extensions/>

I still believe we should create an LibO extensions repository on Sourceforge.net like
<http://sourceforge.net/projects/ooomacros/files/>
or something else. Any Idea how we could start something like that?
Comment 5 Rainer Bielefeld Retired 2011-05-21 23:17:54 UTC
Today most links worked for me on <http://libreplanet.org/wiki/Group:OpenOfficeExtensions/List>, links to download page only broken for cadooo, DrawingTags (You are not authorized to access this page), wollmux, quoots (You are not authorized to access this page)
Comment 6 Rainer Bielefeld Retired 2011-06-05 11:07:18 UTC
I believe it has became worse, it seems as if the OOo Extensions repository has been closed, may be due to future project owner "Apache"?
Comment 7 Rainer Bielefeld Retired 2011-06-12 00:31:15 UTC
It has been an intermitting problem (that might have been fixed). Today in a random sample all 10 extensions were available via libreplanet.

I close th report for now.
Comment 8 Rainer Bielefeld Retired 2011-06-12 09:29:32 UTC
But Photo Album, for example, is not available
Comment 9 Rainer Bielefeld Retired 2011-06-14 10:51:03 UTC
Today not available:

dict_af, AltSearch
(became available after Query in OOo Extensions Data base.)
- DrawingTags: You are not authorized to access this page. 
- quoots
- wollmux
Remained unavailable

Find function on OOo extensions.services.openoffice.org does not work reliable 

It seems that the server or database has some problems, sometimes even the Extension homepage <http://extensions.services.openoffice.org/> can't be reached by clicking the logo on the pages (or elsewhere).
Comment 10 Rainer Bielefeld Retired 2011-07-29 00:08:50 UTC
*** Bug 39624 has been marked as a duplicate of this bug. ***
Comment 11 André Schnabel 2011-08-02 10:10:44 UTC
confirmed, but changed to enhancement and new subject.

The problem is that we cannot to anything as long as we did not setup our own infrastructure. 

CCing Andreas as he is working on this.
Comment 12 Andreas Mantke 2011-08-02 10:27:05 UTC
I have set up the infrastructure on a server of TDF. The files were stored inside the filesystem (not in the Zope database anymore). I've created a new layout for the site.
I had to split off extensions and templates because of the searching result, if you search for all categories (you get all extensions and templates in both PloneSoftwareCenter). The second site is up and running but not under the final URL. This need a short task of an admin.
I had to create a second layout for the template repository. I think this will be done up to the end of this week.
I'm investigating now, if there is a solution for virus scanning during the file upload.
Comment 13 Thorsten Behrens (CIB) 2011-12-22 15:36:51 UTC
Looks all fixed to me.
Comment 14 Björn Michaelsen 2011-12-23 13:25:42 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.