Bug Hunting Session
Bug 36852 - FILEOPEN hard lock when opening files from a remote NFS volume
Summary: FILEOPEN hard lock when opening files from a remote NFS volume
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 46157 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-04 12:00 UTC by Pascal
Modified: 2016-01-19 11:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pascal 2011-05-04 12:00:37 UTC
The problem is on opening a file on an NFS volume, not on save.

Openoffice.org in karmic did not worked well either but no hard lock was observed. It was unable to open nfs files R/W because it was always complaining  that nfs files are locked by 'unknown' (another known bug of ooo on NFS). Since Lucid ooo had the lock problem (bug https://bugs.launchpad.net/openoffice/+bug/577038 on launchpad, bug http://qa.openoffice.org/issues/show_bug.cgi?id=113330 on ooo)

No other application have this problem on NFS.

nfs server is synology ds207+ :

Export :
/volume1/PC        192.168.0.1(rw,sync,no_wdelay,no_root_squash,insecure_locks,anonuid=0,anongid=0)

OS: 
Linux synology 2.6.15 #1354 Sat Oct 23 01:49:30 CST 2010 armv5tejl GNU/Linux synology_88f5281_207+

Kubuntu natty:
mount: 
synology:/volume1/PC on /mnt/pc type nfs (rw,addr=192.168.0.49)


fstab: 
synology:/volume1/PC /mnt/pc  nfs _netdev,nouser,auto,rw,dev,exec,suid   0  0


just for information, opening files on an iSCSI share is working, so the problem is really tight to NFS

Also as noted, a workaround is opening nfs files directly with the command
/usr/lib/libreoffice/program/oosplash.bin -writer "<path to file on nfs share>"

And finally note that the fileselector is sometimes relly sllllloooowwww to discover files on local disks, but when we open start libreoffice with /usr/lib/libreoffice/program/oosplash.bin -writer, then we have no problem to navigate quickly among the file system with the fileselector.

All this seems linked to settings in the libreoffice launch script./usr/lib/libreoffice/program/soffice
Comment 1 Muthu 2011-05-05 00:07:14 UTC
Fridrich-> more info? Thanks!
Comment 2 Alex Thurgood 2011-09-15 06:06:26 UTC
(In reply to comment #0)

> 
> just for information, opening files on an iSCSI share is working, so the
> problem is really tight to NFS
> 


FWIW, there is what appears to be an identical problem on AFS mounted shares, see bug 40907


Alex
Comment 3 Pascal 2011-09-15 10:56:42 UTC
still no fix for that bug ? It renders libreoffice unusable in a shared environnement
Comment 4 Eric 2011-12-24 09:41:07 UTC
This has been a problem for me ever since I started using Libre Office, which is about 2 years, I think. To fix it, I go into the soffice script and comment out everything from "#adjust environment" through the "fi" just before "if [ -z "$SAL_NOOPENGL" ]; then" (do not comment out this last line, I include it only as a reference.)

I use recent versions of Ubuntu, such as 11.04, and Libre Office, as well as OpenOffice (which has the same bug) on various computers, attached to a Synology NAS appliance on which I'm using NFS to share files. The problem is evident on all these computers. 

I also use LibreOffice on Windows and don't notice this problem when accessing files from the Samba service on the NAS.
Comment 5 Pascal 2012-01-03 03:01:05 UTC
still valid in 3.4.4 !
Comment 6 Christopher M. Penalver 2012-01-03 06:08:52 UTC
Pascal, please do not toggle the version. For more on this please see: http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 7 h.goebel 2012-05-23 03:53:41 UTC
This seams to be related or even a duplicate to Bug 46157. The other ticket has screenshots.
Comment 8 h.goebel 2012-05-23 04:36:55 UTC
I can confirm this is related to locking - at least on my system:

Loading/saving fails if the share is mounted using the "lock" option, but works
if the share is mounted with "nolock".

See bug 50276 comment 2 for details.
Comment 9 h.goebel 2012-05-23 04:44:30 UTC
(In reply to comment #0)

> Since Lucid ooo had the lock problem (bug
> https://bugs.launchpad.net/openoffice/+bug/577038 on launchpad, bug

I can confirm: When not setting "SAL_ENABLE_FILE_LOCKING" at all in `soffice`, loading/saving works even if the share is mounted with "lock" enabled.
Comment 10 Björn Michaelsen 2012-06-04 04:39:27 UTC
*** Bug 46157 has been marked as a duplicate of this bug. ***
Comment 11 Hashem Masoud 2012-08-31 17:09:07 UTC
*** Bug 50276 has been marked as a duplicate of this bug. ***
Comment 12 QA Administrators 2015-01-05 17:52:23 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 13 Pascal 2015-01-06 20:44:51 UTC
Bug still present in libreoffice 4.3.3-0ubuntu1 

Same symptoms.

$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 14.10
Release:        14.10
Codename:       utopic
Comment 14 QA Administrators 2016-01-17 20:05:03 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 15 h.goebel 2016-01-19 11:58:18 UTC
Works for me, even with libreoffice 4.4.7.2.