Bug Hunting Session
Bug 36871 - Data Validity for Text Length Kinda Broken
Summary: Data Validity for Text Length Kinda Broken
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.6.3.1 rc
Hardware: All Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-05 07:58 UTC by Scott M. Sanders
Modified: 2015-11-24 16:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
ISBN text-length validation fails. (83.50 KB, application/x-msexcel)
2011-05-05 07:58 UTC, Scott M. Sanders
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott M. Sanders 2011-05-05 07:58:36 UTC
Created attachment 46361 [details]
ISBN text-length validation fails. 

The data validation for text length basically does not work at all as expected presently for LibreOffice or OpenOffice.org Calc, but it does in Excel. 

That is, if you enter anything in such a cell, you will get an error and have the cell data reset. 

Attached is an example XLS; any of the ISBN fields do this.
Comment 1 Noel Power 2011-05-06 03:06:42 UTC
can you give details of which cell has the offending check ?
Comment 2 Scott M. Sanders 2011-05-06 05:01:58 UTC
Any of the ISBN cells -- columns K-M in attached.
Comment 3 GerardF 2011-05-06 12:05:46 UTC
Works for me if entries are Text.
For example, column L Validity is Text length between 12 and 18.
Entering text with less than 12 or more than 18 characters is refused.
Others is accepted.

If your data is number, works also but only if cell is formatted as "text".

May be you expect Text-length validity working with numeric value ?
Comment 4 Scott M. Sanders 2011-05-06 12:20:07 UTC
Yes, the cells are formatted as numbers, which is default for spreadsheets. Good point anyway.

I guess we are expecting LibO/OOo to do this more like a "string" length validator -- as Excel does regardless of data format -- or a more obvious error when it fails as such.
Comment 5 Noel Power 2011-05-09 02:11:45 UTC
going to mark this as a potential enhancement then
Comment 6 Björn Michaelsen 2011-12-22 11:45:51 UTC
Answered -- not NEEDINFO anymore.
Comment 7 Björn Michaelsen 2011-12-23 12:07:32 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 8 Scott M. Sanders 2011-12-30 07:42:40 UTC
It persists in 3.5.0beta2.
Comment 9 Dennis Francis 2015-11-24 13:39:54 UTC
Hi raal

This seems to be fixed as of the current master(may be even before). 
Could you please test and confirm ?

Tested on Fedora 23 64bit on master branch.

Thanks,
Dennis
Comment 10 raal 2015-11-24 16:36:43 UTC
Hello Dennis,
tested with Version: 5.1.0.0.alpha1+
Build ID: 32d4c03cba399ada807b8ec113a3928aa9e3ff7b
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2015-11-17_00:57:30
and Version: 5.1.0.0.alpha1+ (x64)
Build ID: 186f365a2c541c51e404b1fa819f35c9152adaf1
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-11-19_23:26:12

Column L - validity: text lenght
12 - 18 characters

Works OK for text and numbers, closing as WFM.

@Scott - set again to status NEW is you still see the errors. Dev version you can download here: http://dev-builds.libreoffice.org/daily/master/