Download it now!
Bug 36884 - 10n character does not rotate 270 degree
Summary: 10n character does not rotate 270 degree
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Mark Hung
URL:
Whiteboard: target:5.1.0
Keywords:
: 89392 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-05 19:31 UTC by Tomoo Nomura
Modified: 2016-10-25 19:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
sample document (9.89 KB, application/vnd.oasis.opendocument.text)
2011-05-05 19:31 UTC, Tomoo Nomura
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomoo Nomura 2011-05-05 19:31:39 UTC
Created attachment 46380 [details]
sample document

Rotating a Japanese character to 270 degree in a frame does not work correctly while that to 90 degree works correctly.
Comment 1 tester8 2011-06-13 02:09:58 UTC
Reproduced with
Ubuntu 10.04.2 x86
LO 3.4
Comment 2 Björn Michaelsen 2011-12-23 12:06:59 UTC Comment hidden (obsolete)
Comment 3 Tomoo Nomura 2011-12-25 00:36:00 UTC
re-confirmed. Still exists.
LOdev 3.5.0beta2 
builed ID: c3bcb31-760cc4d-f39cf3d-1b2857e-60db978
Comment 4 A (Andy) 2013-04-27 17:00:35 UTC
Unfortunately, I can not read Japanese.  Therefore, I am not sure, but it seems to me as the text is rotated as expected (not reproducible with LO 4.0.2.2 [Win7 Home, 64bit])?  But because I can not read Japanese letters I am not really sure.

Does this issue still persist for you with the latest release of LO?
Comment 5 Urmas 2013-04-27 19:40:28 UTC
Confirmed with 4.0.3.

Japanese characters rotated by 270° appear to be displayed as for vertical writing.
Comment 6 QA Administrators 2015-03-04 02:21:56 UTC Comment hidden (obsolete)
Comment 7 Tomoo Nomura 2015-03-05 00:58:33 UTC
Lo 4.4.1.2rc2 still exists, nothing changed.
Debian Jessie kernel 3.17-1-amd64
Comment 8 Tomoo Nomura 2015-03-05 02:06:06 UTC
(In reply to Tomoo Nomura from comment #7)
> Lo 4.4.1.2rc2 still exists, nothing changed.
> Debian Jessie kernel 3.17-1-amd64

correction 4.4.1.2rc  not  4.4.1.2rc2
Comment 9 Jean-Baptiste Faure 2015-03-05 08:23:48 UTC
Reversed the version number to the previous one.

Please, do not change the version number which is intended to show the oldest version in which the bug has been observed.

Best regards. JBF
Comment 10 Mark Hung 2015-08-02 00:59:41 UTC
*** Bug 89392 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2015-08-15 21:30:16 UTC
Mark Hung committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=929954e0108897c4882660b4ce9cb5d4cf1077ec

Fix tdf#36884 10n character does not rotate 270 degree

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Julien Nabet 2016-06-12 09:25:52 UTC
I gave a try with LO Debian package 5.1.4.1, perhaps I missed something but it seems it still doesn't work.

Mark: are you still working on it? If yes, please put status to ASSIGNED, if no, you can unassign yourself.
Comment 13 pietro.pangallo 2016-06-17 10:00:12 UTC
Fixed in:
Version: 5.1.3.2
Build ID: 10m0(Build:2)
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default; 
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

status changed from: NEW -> RESOLVED WORKFORME
Comment 14 Tomoo Nomura 2016-06-18 00:59:13 UTC
I confirmed it works correctly in 
Version: 5.1.3.2
Build ID: 1:5.1.3-1
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
Locale: ja-JP (en_US.utf8)

Thanks,
Tomoo