Bug 36923 - UI problems under KDE SC 4.6.2
Summary: UI problems under KDE SC 4.6.2
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 Beta3
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Lubos Lunak
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-06 15:00 UTC by RGB
Modified: 2011-05-13 09:46 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Screen shot showing the problem (32.09 KB, image/png)
2011-05-06 15:00 UTC, RGB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description RGB 2011-05-06 15:00:09 UTC
Created attachment 46410 [details]
Screen shot showing the problem

On the attached screen shot the app in the background is LibO 3.4 beta 3 while that on top is LibO 3.3.2, both on openSUSE 11.4 64 bits.
As you can see, 3.4 beta is having trouble with desktop integration (it uses some general UI decoration) and it also have *severe* repainting problems, not present on 3.3.2.
It seems that 3.4 beta is not reading neither the kde nor the gtk vcl plugin.
Using OOO_FORCE_DESKTOP=kde/gnome/native or QT_GRAPHICSSYSTEM=native does not change the problem (just the icon theme).
Comment 1 Noel Power 2011-05-09 02:46:07 UTC
for lubos I guess
Comment 2 RGB 2011-05-13 09:46:10 UTC
Just started beta 5 and now everything seems ok. The visual integration with kde is just beautiful... good work!