Bug 37004 - Flip image (horizontally/vertically) broken when copying from MS-Paint (Win7)
Summary: Flip image (horizontally/vertically) broken when copying from MS-Paint (Win7)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-09 04:00 UTC by Stephan Zietsman
Modified: 2015-04-22 13:41 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan Zietsman 2011-05-09 04:00:01 UTC
When copying an image to the clipboard (in MS-Paint) and pasting it into LibO Writer, the "flip vertical" / "flip horizontal" tick-box does nothing.

 -= To reproduce =-

Take a screen-shot, any random screen-shot (PrtScn - Print-screen button)
Open MS-Paint (Start menu -> All Programs -> Accessories -> Paint)
Paste screen-shot (Ctrl + v)
Copy pasted screen-shot to clipboard (Ctrl + c)

Open LibreOffice
Create new text document (File -> New -> Text Document)
Paste image from clipboard (Ctrl + v)
Double-click pasted image (or right-click -> Picture...)
Select "Picture" tab
Under the "Flip" section, tick the box "Flip Vertically"
Click OK

Expected result: Image flips vertically
Actual result: Nothing happens

The same applies to "Flip Horizontally" (irrespective of radio button position).

 -= End of reproduction =-

I have also noticed the following:

1. Using "Paste Special" (Ctrl + Shift + v) and selecting "GDI metadata" produces the same problem (image cannot be flipped).


2. Using "Paste special" and selecting "Paintbrush Picture" produces inconsistent result.

   2.1 If image was pasted with "Ctrl + v" FIRST, with the image still selected and then pasted again with "Ctrl + Shift + v" -> "Paintbrush Picture", it acts identically to pasting as "GDI metadata" (cannot be flipped, image looks "normal")
 
   2.2 If the image was NOT pasted with Ctrl + v first, but rather pasted with Ctrl + Shift + v -> Paintbrush Picture instead (i.e. pasted into blank document), the picture is pasted as a smaller version, almost like a thumbnail.  The pasted image cannot be flipped.


3. Using "Paste special" and selecting "Bitmap" works as expected (image can be flipped correctly)

4. Pasting the screen-shot directly into LibO writer (not pasting and copying from MS-Paint) works as expected (image can be flipped correctly)
Comment 1 Stephan Zietsman 2011-05-09 04:06:26 UTC
I'm marking it as a "Minor" issue because a workaround exists (Paste Special -> Bitmap)

FYT,

Windows 7 Professional 64-bit (Service Pack 1)

LibreOfficePortable 3.3.2 (as from PortableApps.com)

LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2
Comment 2 Björn Michaelsen 2011-12-23 12:01:50 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-02-28 04:48:35 UTC
reproduced in 3.5.0 beta 3 on Windows XP 32 bit
Problem with copy from Paint, from Gimp Ok. Problem only in Writer, Calc and Impress works correctly. And in Writer in picture preview flip seen correctly, but in document nothing happens.
Comment 4 sasha.libreoffice 2012-02-28 04:50:04 UTC
@ Tor
Please, look at this. Windows specific problem, Writer wrong interacts with Paint
Comment 5 QA Administrators 2015-04-01 14:40:19 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-01
Comment 6 Buovjaga 2015-04-21 16:21:05 UTC
None of the problems in description exist anymore. WFM.

Win 7 Pro 64-bit Version: 5.0.0.0.alpha0+ (x64)
Build ID: 211c12b9c64facd1c12f637a5229bd6a6feb032a
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-04-18_01:51:17
Locale: fi_FI
Comment 7 Stephan Zietsman 2015-04-22 13:41:34 UTC
I can confirm that the bug does not seem to be present anymore.  I.e., it works for me.

-- 
Windows 7 Professional 32-bit (Service Pack 1)

Running LibreOfficePortable (as from portableapps.com)
Version 4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)