Bug 37175 - Install Crash on Select All Additional Language Packs
Summary: Install Crash on Select All Additional Language Packs
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.1 RC1
Hardware: All Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-13 05:37 UTC by Scott M. Sanders
Modified: 2013-11-24 19:42 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Windows Error Report Files (21.51 KB, application/zip)
2011-05-13 05:40 UTC, Scott M. Sanders
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Scott M. Sanders 2011-05-13 05:37:38 UTC
In custom setup, when I select to install all additional language packs, I always get the Windows XP Data Execution Prevention (DEP) message, which terminates setup.

Attached are the Windows Error Reporting files, and here is the Windows error signature:

EventType : BEX     P1 : msiexec.exe     P2 : 4.5.6001.22159     P3 : 480573de
P4 : unknown     P5 : 0.0.0.0     P6 : 00000000     P7 : 00000000     
P8 : c0000005     P9 : 00000008

I am guessing some workarounds include either excluding Windows Installer from DEP or install less additional packages. I will look into this soon.
Comment 1 Scott M. Sanders 2011-05-13 05:40:18 UTC
Created attachment 46682 [details]
Windows Error Report Files
Comment 2 Scott M. Sanders 2011-05-13 06:37:29 UTC
I excepted Windows Installer from DEP, and it worked, but it's probably not the most secure workaround unless excepted only during LibO setup and one really trusts LibO enough.
Comment 3 Don't use this account, use tml@iki.fi 2011-05-13 06:52:40 UTC
Nobody else has reported this. Is DEP available by default on XP, or have you installed some 3rd-party add-on for it? Is DEP on XP known for false positives? I can't imagine why installing LibreOffice would require msiexec to execute dynamically generated code.
Comment 4 Scott M. Sanders 2011-05-13 10:14:15 UTC
DEP is default on XP; you can only exclude apps from it.

I have had occasional DEP false-positives; I don't recall what they were though.
Comment 5 Scott M. Sanders 2011-07-05 06:02:11 UTC
It's there in 3.4.1 too, as a Just-in-Time (JIT) debug error.
Comment 6 Björn Michaelsen 2011-12-23 12:03:50 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 7 Scott M. Sanders 2011-12-23 14:58:13 UTC
It works in 3.4.5rc1 and 3.5beta1. Thanks.
Comment 8 Scott M. Sanders 2012-01-30 05:52:12 UTC
This is back in 3.5.0 RC2. It was OK with RC1. Both were installed on my new Win 7 Pro SP1 64-bit box.

It just says that "Windows installer has stopped working."

It happened the first two times, but it worked the third time..?
Comment 9 Scott M. Sanders 2012-02-07 10:37:09 UTC
OK, it happens if I try to select all languages at once ("This feature, and all subfeatures, will be installed on local hard drive.") while the installer is still slowly "compiling the cost for that feature."
Comment 10 Andras Timar 2012-04-26 04:45:24 UTC
(In reply to comment #9)
> OK, it happens if I try to select all languages at once ("This feature, and all
> subfeatures, will be installed on local hard drive.") while the installer is
> still slowly "compiling the cost for that feature."

I cannot reproduce it, maybe my computer is too fast, and I cannot click quickly enough to trigger the crash. Nevertheless, it is not something that we can fix.