Download it now!
Bug 37252 - Crashing when using "Function Wizard" button
Summary: Crashing when using "Function Wizard" button
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: Other Windows (All)
: medium critical
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.4
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-16 06:43 UTC by t.guilbert17
Modified: 2015-03-28 18:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Exercice file (10.43 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-05-16 06:45 UTC, t.guilbert17
Details

Note You need to log in before you can comment on or make changes to this bug.
Description t.guilbert17 2011-05-16 06:43:23 UTC
Hello,

1) go to file "bug_index.ods"
2) select cell K3
3) click on the formula button

LibreOffice crashes !

Thanks !
Comment 1 t.guilbert17 2011-05-16 06:45:04 UTC
Created attachment 46762 [details]
Exercice file
Comment 2 vitriol 2011-05-16 06:52:29 UTC
I confirm under Win7. Regression from 3.3.2
Comment 3 Kohei Yoshida 2011-05-17 12:52:33 UTC
I can't reproduce.  It opens up fine for me.  Can you give me a stack trace of your crash?
Comment 4 vitriol 2011-05-17 13:00:01 UTC
I use Win7 (changed platform). Simply open attached document, select cell K3 (there is an error message into the cell) end press Function Wizard button.
Comment 5 Kohei Yoshida 2011-05-17 18:06:08 UTC
Yup, this crash is only for Windows, though I don't know why it should be Windows-only.
Comment 6 Kohei Yoshida 2011-05-17 18:57:04 UTC
Proposed patch sent to the mailing list for review.  It's a pretty simple fix so I'm sure it'll make it in for 3.4.
Comment 8 vitriol 2011-05-18 07:13:27 UTC
Thank you Kohei.