Download it now!
Bug 37277 - Formulas in table are inserted into the wrong cell
Summary: Formulas in table are inserted into the wrong cell
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.0 Beta5
Hardware: x86-64 (AMD64) All
: medium blocker
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.4
  Show dependency treegraph
 
Reported: 2011-05-17 01:28 UTC by Johannes Weberhofer
Modified: 2011-10-29 08:43 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Weberhofer 2011-05-17 01:28:17 UTC
When I enter a formula, the formula is inserted into the wrong cell.

Steps to reproduce:

* Create new doc

* Insert a tables with 3 rows, 1 column

* in the first line, insert the formula "=1"

* in the second line press F2 and click on the first line (to insert =<A1>

* Press <Enter>

Result: **Fehlerhafter Ausfdruck** in line 1, because the formula =<A1> has been inserted in line one instead of line 2

It is always reproduceable including the libreoffice-3-4~2011-05-16_21_17_52_LibO_3.4.0beta5_MacOS_x86_install_en-US built.
Comment 1 vitriol 2011-05-17 01:38:44 UTC
Reproducible on Win7 too. Regression from 3.3.2
Comment 2 vitriol 2011-05-17 01:40:02 UTC
Nominating as blocker.
Comment 3 Rainer Bielefeld Retired 2011-05-17 02:18:45 UTC
It seems that insertion of a calculation into a table works only 1 time, afterwards all further calculations will be inserted "somehow" into the cell of the first calculation. 

@Cédric:
Your area? Please feel free to reassign if I picked the wrong assignee.
Comment 4 Noel Power 2011-05-17 07:59:05 UTC
fixed on libreoffice-3.4 branch

http://cgit.freedesktop.org/libreoffice/writer/commit/?h=libreoffice-3-4&id=901ea08e2ef394e06d54fd4a3bd572a7dfe409fa

works perfectly for me after the patch