Bug 37305 - Errors in neon library when building from master
Summary: Errors in neon library when building from master
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-17 23:45 UTC by Alex Thurgood
Modified: 2012-08-31 14:13 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alex Thurgood 2011-05-17 23:45:57 UTC
When building from master on Mac OSX, I get the following errors :


ne_compress.c: In function 'process_footer':
ne_compress.c:146: warning: format '%u' expects type 'unsigned int', but argument 3 has type 'size_t'
ne_basic.c: In function 'ne_get_range':
ne_basic.c:208: warning: format '%ld' expects type 'long int', but argument 4 has type 'ne_off_t'
ne_basic.c:213: warning: format '%ld' expects type 'long int', but argument 4 has type 'ne_off_t'
ne_basic.c:213: warning: format '%ld' expects type 'long int', but argument 5 has type 'ne_off_t'
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_i18n.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_locks.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_md5.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_props.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_redirect.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_request.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_session.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_socket.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_socks.c
ne_request.c: In function 'aborted':
ne_request.c:189: warning: format '%d' expects type 'int', but argument 3 has type 'ssize_t'
ne_request.c: In function 'body_fd_send':
ne_request.c:335: warning: format '%ld' expects type 'long int', but argument 4 has type 'ne_off_t'
ne_request.c: In function 'send_request_body':
ne_request.c:391: warning: format '%d' expects type 'int', but argument 3 has type 'ssize_t'
ne_request.c:402: warning: format '%d' expects type 'int', but argument 3 has type 'ssize_t'
ne_request.c: In function 'set_body_length':
ne_request.c:498: warning: format '%ld' expects type 'long int', but argument 4 has type 'ne_off_t'
ne_request.c: In function 'read_response_block':
ne_request.c:760: warning: format '%u' expects type 'unsigned int', but argument 3 has type 'size_t'
ne_request.c:774: warning: format '%d' expects type 'int', but argument 3 has type 'ssize_t'
ne_request.c:780: warning: format '%d' expects type 'int', but argument 3 has type 'ssize_t'
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_string.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_uri.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_utils.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_xml.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_xmlreq.c
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_openssl.c
ne_socket.c: In function 'writev_raw':
ne_socket.c:574: warning: implicit declaration of function 'writev'
Compiling: neon/unxmacxi.pro/misc/build/neon-0.29.5/src/ne_ntlm.c
ne_xml.c: In function 'ne_xml_doc_encoding':
ne_xml.c:205: warning: pointer targets in return differ in signedness
ne_xml.c: In function 'declare_nspaces':
ne_xml.c:233: warning: pointer targets in passing argument 1 of 'strcmp' differ in signedness
ne_xml.c:235: warning: pointer targets in passing argument 1 of 'ne_strdup' differ in signedness
ne_xml.c:235: warning: pointer targets in assignment differ in signedness
ne_xml.c:236: warning: pointer targets in passing argument 1 of 'strncmp' differ in signedness
ne_xml.c:252: warning: pointer targets in passing argument 1 of 'ne_strdup' differ in signedness
ne_xml.c:252: warning: pointer targets in assignment differ in signedness
ne_xml.c:253: warning: pointer targets in passing argument 1 of 'ne_strdup' differ in signedness
ne_xml.c:253: warning: pointer targets in assignment differ in signedness
ne_xml.c: In function 'expand_qname':
ne_xml.c:267: warning: pointer targets in passing argument 1 of 'strchr' differ in signedness
ne_xml.c:267: warning: pointer targets in assignment differ in signedness
ne_xml.c:276: warning: pointer targets in passing argument 1 of 'ne_strdup' differ in signedness
ne_xml.c:276: warning: pointer targets in assignment differ in signedness
ne_xml.c:284: warning: pointer targets in passing argument 2 of 'resolve_nspace' differ in signedness
ne_xml.c:287: warning: pointer targets in passing argument 1 of 'ne_strdup' differ in signedness
ne_xml.c:287: warning: pointer targets in assignment differ in signedness
ne_xml.c:288: warning: pointer targets in assignment differ in signedness
ne_xml.c: In function 'start_element':
ne_xml.c:330: warning: pointer targets in passing argument 3 of 'hand->startelm_cb' differ in signedness
ne_xml.c:330: warning: pointer targets in passing argument 4 of 'hand->startelm_cb' differ in signedness
ne_xml.c:330: warning: passing argument 5 of 'hand->startelm_cb' discards qualifiers from pointer target type
ne_xml.c: In function 'char_data':
ne_xml.c:373: warning: pointer targets in passing argument 3 of 'elm->handler->cdata_cb' differ in signedness
ne_xml.c: In function 'end_element':
ne_xml.c:391: warning: pointer targets in passing argument 3 of 'elm->handler->endelm_cb' differ in signedness
ne_xml.c:391: warning: pointer targets in passing argument 4 of 'elm->handler->endelm_cb' differ in signedness
ne_xml.c: In function 'resolve_nspace':
ne_xml.c:442: warning: pointer targets in passing argument 1 of 'strlen' differ in signedness
ne_xml.c:444: warning: pointer targets in return differ in signedness
ne_xml.c: In function 'ne_xml_resolve_nspace':
ne_xml.c:463: warning: pointer targets in return differ in signedness
ne_xml.c: In function 'ne_xml_create':
ne_xml.c:472: warning: pointer targets in assignment differ in signedness
ne_xml.c: In function 'ne_xml_parse_v':
ne_xml.c:542: warning: pointer targets in passing argument 2 of 'ne_xml_parse' differ in signedness
ne_xml.c: In function 'ne_xml_parse':
ne_xml.c:553: warning: format '%u' expects type 'unsigned int', but argument 3 has type 'size_t'
ne_xml.c:561: warning: format '%u' expects type 'unsigned int', but argument 3 has type 'size_t'
echo ../../../../../unxmacxi.pro/slo/ne_207.o ../../../../../unxmacxi.pro/slo/ne_acl3744.o ../../../../../unxmacxi.pro/slo/ne_alloc.o ../../../../../unxmacxi.pro/slo/ne_auth.o ../../../../../unxmacxi.pro/slo/ne_basic.o ../../../../../unxmacxi.pro/slo/ne_compress.o ../../../../../unxmacxi.pro/slo/ne_dates.o ../../../../../unxmacxi.pro/slo/ne_i18n.o ../../../../../unxmacxi.pro/slo/ne_locks.o ../../../../../unxmacxi.pro/slo/ne_md5.o ../../../../../unxmacxi.pro/slo/ne_props.o ../../../../../unxmacxi.pro/slo/ne_redirect.o ../../../../../unxmacxi.pro/slo/ne_request.o ../../../../../unxmacxi.pro/slo/ne_session.o ../../../../../unxmacxi.pro/slo/ne_socket.o ../../../../../unxmacxi.pro/slo/ne_socks.o ../../../../../unxmacxi.pro/slo/ne_string.o ../../../../../unxmacxi.pro/slo/ne_uri.o ../../../../../unxmacxi.pro/slo/ne_utils.o ../../../../../unxmacxi.pro/slo/ne_xml.o ../../../../../unxmacxi.pro/slo/ne_xmlreq.o ../../../../../unxmacxi.pro/slo/ne_openssl.o ../../../../../unxmacxi.pro/slo/ne_ntlm.o | xargs -n1 nm -gx | /Users/alex/DevHack/git/libo/solenv/bin/addsym-macosx.sh ../../../../../unxmacxi.pro/misc/exports_neon.map.symbols-regexp ../../../../../unxmacxi.pro/misc/exports_neon.map.symbols-regexp.tmp >> ../../../../../unxmacxi.pro/misc/exports_neon.map.exported-symbols
cp ../../../../../unxmacxi.pro/misc/exports_neon.map.exported-symbols ../../../../../unxmacxi.pro/misc/exports_neon.map
Making:    all_neon.dpslo
/Users/alex/DevHack/git/libo/solenv/bin/checkdll.sh -L../../../../../unxmacxi.pro/lib -L/Users/alex/DevHack/git/libo/solver/340/unxmacxi.pro/lib  ../../../../../unxmacxi.pro/lib/libneon.dylib
Making:    libneon.dylib
ld: warning: cannot export hidden symbol _ne__ssl_set_verify_err from ../../../../../unxmacxi.pro/slo/ne_session.o
ld: warning: cannot export hidden symbol _ne__sock_sslsock from ../../../../../unxmacxi.pro/slo/ne_socket.o
ld: warning: cannot export hidden symbol _ne__negotiate_ssl from ../../../../../unxmacxi.pro/slo/ne_openssl.o
ld: warning: cannot export hidden symbol _ne__ssl_init from ../../../../../unxmacxi.pro/slo/ne_openssl.o
ld: warning: cannot export hidden symbol _ne__ssl_exit from ../../../../../unxmacxi.pro/slo/ne_openssl.o
Checking DLL ../../../../../unxmacxi.pro/lib/libneon.dylib ...dmake: Executing shell macro: ls $(foreach,j,$(OUT2LIB) $(LB)/$(j:f)) |              (grep -v '\.a$$' || test $$? = 1)



Alex
Comment 1 Björn Michaelsen 2011-12-23 12:01:30 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Florian Reisinger 2012-08-14 14:01:18 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 3 Florian Reisinger 2012-08-14 14:02:24 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:07:01 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:09:05 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian