Bug Hunting Session
Bug 37318 - FILEOPEN: .pptx picture with round corners appears with square corners
Summary: FILEOPEN: .pptx picture with round corners appears with square corners
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 45496 (view as bug list)
Depends on:
Blocks: PPTX
  Show dependency treegraph
 
Reported: 2011-05-18 07:09 UTC by sasha.libreoffice
Modified: 2019-09-22 16:20 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
slide with picture that has round corners crop and 3D frame (74.39 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2011-05-18 07:09 UTC, sasha.libreoffice
Details
screenshot of slide with round corners (106.38 KB, image/jpeg)
2011-05-18 07:43 UTC, sasha.libreoffice
Details
another example pptx (50.91 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2016-10-13 19:13 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2011-05-18 07:09:33 UTC
Created attachment 46863 [details]
slide with picture that has round corners crop and 3D frame

This slide has picture in middle and some text on russian. Picture in pptx file is with round corner crop and with 3D-looking frame. In Impress picture appears without crop and with black frame.

This produced on LibreOffice 3.4 beta 5 on Mandriva 64 bit and Windows XP 32 bit

Black frame looks very gloomily or mournfully in this situation.Gray or brown frame would be more joyful. (if use simple frame and not 3D )
What about 3D-looking, it is not very important, because on porjector it seen not clearly.
Round corner crop is interesting function, it my be added as functionality into office. If not, than picture must be processed at import time to look as in MSOffice 2007.

PS: text in upper frame has lost its shadow, this is another bug, but is not very important at this time.
Comment 1 sasha.libreoffice 2011-05-18 07:43:51 UTC
Created attachment 46865 [details]
screenshot of slide with round corners

If developers decide not add 3D frames functionality, it is enough to add white color to frame color (to color become brighter). It will look good.
Comment 2 André Schnabel 2011-06-18 14:32:25 UTC
confirmed using LibO 3.4.1RC1 on linux 32bit

this looks very similar to bug 37315
Comment 3 A (Andy) 2013-03-28 22:33:52 UTC
reproducible with LO 4.0.1.2 (Win7 Home, 64bit)

this issue is really buggy and annoying -> increased the importance
Comment 4 Thorsten Behrens (CIB) 2013-04-04 08:42:47 UTC Comment hidden (obsolete)
Comment 5 tommy27 2014-07-18 19:56:11 UTC Comment hidden (obsolete)
Comment 6 tommy27 2014-07-18 19:58:16 UTC
same issue in OOo 3.3.0 and AOO 4.1.0
bug is inherited from OOo
Comment 7 tommy27 2015-06-22 19:09:03 UTC
still present in LibO 4.4.3.2 and 5.1.0.0.alpha1+
Build ID: ba70050dc37f82306a8a3c5815372a4b9fff18fc
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_06:35:49
Locale: en-US (it_IT)
Comment 8 QA Administrators 2016-09-20 10:10:48 UTC Comment hidden (obsolete)
Comment 9 Timur 2016-10-13 19:13:33 UTC Comment hidden (obsolete)
Comment 10 Timur 2016-10-13 19:21:48 UTC
*** Bug 45496 has been marked as a duplicate of this bug. ***
Comment 11 Timur 2016-10-13 19:22:53 UTC
Another example: attachment 56444 [details] from Bug 45496 marked as dupe.
Comment 12 QA Administrators 2017-10-23 14:06:24 UTC Comment hidden (obsolete)
Comment 13 Timur 2017-11-16 15:24:42 UTC Comment hidden (obsolete)
Comment 14 Roman Kuznetsov 2018-09-23 20:52:41 UTC
still repro in

Version: 6.2.0.0.alpha0+
Build ID: 1aa37aa6bee19099b57555a6d839992b054aa405
CPU threads: 4; OS: Windows 10.0; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-09-23_10:17:54
Locale: ru-RU (ru_RU); Calc: threaded
Comment 15 Buovjaga 2019-09-22 16:20:36 UTC
Rounded corners now appear, closing

Version: 6.4.0.0.alpha0+ (x64)
Build ID: bda1d88f2bfa21202725ab9c567b3cccba3c1f0b
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2019-09-15_04:18:20
Locale: fi-FI (fi_FI); UI-Language: en-US
Calc: threaded