Bug Hunting Session
Bug 37382 - EDITING LO can paste data via third/middle click if "Edit File" is turned off
Summary: EDITING LO can paste data via third/middle click if "Edit File" is turned off
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 72179 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-05-19 10:55 UTC by Christopher M. Penalver
Modified: 2015-04-25 09:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example4.odp (13.36 KB, application/vnd.oasis.opendocument.presentation)
2011-05-19 10:55 UTC, Christopher M. Penalver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-05-19 10:55:46 UTC
Created attachment 46915 [details]
example4.odp

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-impress
libreoffice-impress:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        500 http://us.archive.ubuntu.com/ubuntu/ natty-proposed/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Impress via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/482548/+attachment/1894449/+files/example4.odp && stat example4.odp && chmod -wxXst example4.odp && stat example4.odp && loimpress -nologo example4.odp

copy a hyperlink from a webbrowser then:

with a 2 button laptop touchpad, click the left and right buttons simultaneously into a cell or with a three button external mouse click the middle button and nothing pastes because the file is read only.

-OR-

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/482548/+attachment/1894449/+files/example4.odp && loimpress -nologo example4.odp

File -> Properties -> Security tab -> check Open File read-only -> OK button -> close file -> re-open and with a 2 button laptop touchpad, click the left and right buttons simultaneously into a cell or with a three button external mouse click the middle button and nothing pastes because the file is read only.

4) What happens instead is it pastes into the file. It cannot be undone via Ctrl+Z. The file cannot be saved over to the original file name with the pasted in changes, however, the file can be saved with the changes into a file with another name which will not be read-only.
Comment 1 Björn Michaelsen 2011-12-23 12:06:03 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 againsttcpa84 2011-12-27 04:47:53 UTC
I wrote the following comment on the corresponding launchpad bug, but somehow it did not appear here... --> copy-paste

****
Bug still exists in LibreOffice 3.5 beta2 (Ubuntu Maverick 10.10)

If I open a read-only file in Impress, I cannot delete/insert/modify any content (logical).
 However, if I select a text let's say in Firefox, I can insert it with a middle click (or simultaneous right and left click) anywhere in the document but not remove it anymore.
 The same thing happens, if I open a read-and-writable file, but set its status to "uneditable" by clicking on the icon "Edit File" in the toolbar.

This bug appears in Impress and in Draw, but not in Calc (pop-up says protected cells cannot be modified) and not in Writer (silently fails).

OT: I looove the new handle bars :-D
****
Comment 3 starmatz71 2012-01-22 11:51:32 UTC
I can confirm this behavior for LibreOffice 3.4.4. in Ubuntu 11.10 64-Bit.

I can not confirm this for WindowsXP and LibreOffice 3.5.0rc1.

I believe, this behavior has to do with the methode of Linux to paste marked text with the middle mousebutton and LibO does not recognize that? Is this a different codebase?

I change the release to 3.4.4. beacause this is the current stable branch and the bug is still in this release, it seems to be Linux related.
Comment 4 Christopher M. Penalver 2012-01-22 12:08:18 UTC
starmatz71@yahoo.de, please do not toggle the version. For more on this please see http://wiki.documentfoundation.org/BugReport_Details#Version
Comment 5 Papamatti 2013-04-20 14:05:34 UTC
I can confirm this behavior on Ubuntu 13.04 Beta with Libre Office V4.0.2.2.

Reproduction:
1. Open impress
2. Save the empty file everywhere you want
3. Turn off "Edit File" button.

Normally you cannot edit the impress file anymore.

4. Get a text from everywhere (texteditor, internet) and copy it to the clipboard
5. Switch back to impress and press the middle mousebutton.

You can see you insert textboxes into the impress file and impress does not realise it as a change, you can switch "Edit File" on and off without asking for saving the document after a change!

In WindowsXP you cannot paste data into impress if "Edit File" is turned off, because paste is greyed out and you cannot click onto it. In Ubuntu you can, paste is not greyed out!

I have test it with LO Draw, and the behavior is the same in Ubuntu!

This is a bit annoying, because you can modify documents while a presentation accidently!

Can someone test this on other platforms? (Mac, Win7/8, other distros/GUIs)
Comment 6 QA Administrators 2013-11-04 22:18:03 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team
Comment 7 Jean-Baptiste Faure 2013-11-30 17:31:05 UTC
I can confirm this behavior on Ubuntu 13.10 x86-64 with upstream versions 4.0.6, 4.1.5.0.0+ and 4.2.0.0.beta1.

Set status back to NEW.

Best regards. JBF
Comment 8 QA Administrators 2015-04-19 03:22:29 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   *Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later)
   https://www.libreoffice.org/download/

   *If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
   *If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   *Update the version field
   *Reply via email (please reply directly on the bug tracker)
   *Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 
4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-04-18
Comment 9 Jean-Baptiste Faure 2015-04-21 07:21:39 UTC
Still reproducible with LibreOffice 4.4.4.0.0+ built at home under Ubuntu 14.10 x86-64.
BUT, not reproducible in LibreOffice 5.0.0.0.alpha1+ built at home under Ubuntu 14.10 x86-64.

So closing as WorksForMe. Please, feel free to reopen if you disagree.

Best regards. JBF
Comment 10 Jean-Baptiste Faure 2015-04-25 09:46:29 UTC
*** Bug 72179 has been marked as a duplicate of this bug. ***