Bug Hunting Session
Bug 37433 - German hyphenation not working with 3.4rc1 (version 20.5.2011)
Summary: German hyphenation not working with 3.4rc1 (version 20.5.2011)
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.4.0 RC1
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-21 07:58 UTC by gerdl
Modified: 2011-08-30 12:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case document 'Hyphenation' en, fr, de: hyphenation_en_fr_de.odt (20.36 KB, application/vnd.oasis.opendocument.text)
2011-05-22 14:53 UTC, manj_k
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gerdl 2011-05-21 07:58:10 UTC
German hyphenation ist not working in calc 3.4 rc1 20.5.2011.
calc says that the hyphenation is set for the not worken region. 
If you transfer an calc sheet created with 3.4 rc1 into writer 3.3.2 and open it and click into the sheet under 3.3.2 the missing hyphenation is made.
Comment 1 manj_k 2011-05-22 14:50:23 UTC
I can confirm that hyphenation is broken with the bundled German (de-DE) dictionary, version 2011-05-05;
tested [on WinXP 32b] with LibO 3.4 Beta5, LibO 3.4 RC1, LibO 3.4 nightly v2011-05-20 (the same bug with OOo 3.4 Beta1 and OOo-dev DEV300m106).

Hyphenation works well with the also tested languages English(USA) and French (France).

How to reproduce (Writer):
[English, French and German (DE) dictionaries installed/enabled.]

1. Menu Tools > Options > Language Settings > Writing Aids > Options >
[ ] Hyphenate without inquiry [disabled]
2. Open the attached text document ('hyphenation_en_fr_de.odt').

3.1 Select paragraph [1] [Text body, English (USA)]
3.2 Menu Tools > Language > Hyphenation...
3.3 Pop-up window with dialog 'Hyphenation (English (USA))' [psy=cho-analysis.]
OK - as expected

4.1 Select paragraph [2] [Text body, French (France)]
4.2 Menu Tools > Language > Hyphenation...
4.3 Pop-up window with dialog 'Hyphenation (French (France))' [Au-triche]
OK - as expected

5.1 Select paragraph [3] [Text body, German (Germany)]
5.2 Menu Tools > Language > Hyphenation...
5.3 Message "Hyphenation completed"
Expected: 
Pop-up window with dialog 'Hyphenation (German (Germany)) [Kai-sertum] etc.
Bug: 
Hyphenation unavailable

The hyphenation for German (Germany) could be enabled as follows:
Go to <Program Files>\<LibO_340>\share\extensions\dict-de-DE\...
Replace 'hyph_de_DE.dic' (v2011.05.05) with hyph_de_DE.dic (v2010.12.04)

So it seems to be a bug with the German (de-DE) dictionary 
(file 'hyph_de_DE.dic')

(Not tested: de-AT, de-CH)
(Added Karl Zeiler to CC List)
Comment 2 manj_k 2011-05-22 14:53:30 UTC
Created attachment 47020 [details]
Test case document 'Hyphenation' en, fr, de: hyphenation_en_fr_de.odt
Comment 3 Yifan Jiang 2011-05-22 22:37:59 UTC
Hello, Petr, I saw this as well. Would you like to have a review? Thanks!
Comment 5 manj_k 2011-05-24 01:13:53 UTC
Tested with 'nightly' LibO 3.4 v2011-05-23 [on WinXP]
(libreoffice-3-4~2011-05-23_13.32.39_LibO_3.4.0rc1_Win_x86_install_multi.exe):

Automatic and manual hyphenation 
[German (Austria), German (Germany), German (Switzerland)]
work fine with the modified dictionaries 'hyph_de_AT.dic', 'hyph_de_DE.dic', 'hyph_de_CH.dic'.