Download it now!
Bug 37640 - [insert figure] convert or gs as child of soffice.bin are CPU blocking
Summary: [insert figure] convert or gs as child of soffice.bin are CPU blocking
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-26 12:05 UTC by David Kremer
Modified: 2015-03-04 20:09 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
.fodt template file and the linked .eps figure (10.81 KB, application/zip)
2011-05-26 12:05 UTC, David Kremer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Kremer 2011-05-26 12:05:14 UTC
Created attachment 47197 [details]
.fodt template file and the linked .eps figure

Hello,

I worked with libreoffice for some times. 

I noticed something a bit strange... 

When I link a figure into my document (writer), and I try to make some manipulation on the layout, or in the figure by "select then right-click on the figure", libreoffice freezes for some time. 

I noticed also that it is due to ghostscript or convert instances launched as child process by libreoffice, I guess doing something with the linked figure.

It could be the same problem with not linked figure or in a more wide variety of case, however under the above circumstances, the bug is reproducible.

I would make some comments. it's disturbing that vectoriel graphics take so many cpu time, since it's designed to be scaled without too much computational effort, compared to bitmap formats.

Secondly, a WYSIWYG program shouldn't take so much CPU, because it's really blocking, and not in the WYSIWYG fashion to wait for the informations to be displayed. 

Thirdly, a CPU blocking program on a desktop is a serious drawback, even if it's an office suite.

I hope not to be too harsh...
Comment 1 Jean-Baptiste Faure 2011-05-29 07:39:25 UTC
As far as I know, LibreOffice does not have code to view and manipulate EPS file. It use external programs, if available, to do generate on the fly the missing preview in the eps file. Needed external programs are generally available under Linux but it is not the case for MS-Windows.
Under MS-Windows LibreOffice does not show the chart in your eps file.
Comment 2 Björn Michaelsen 2011-12-23 12:01:23 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 3 sasha.libreoffice 2012-01-25 21:37:26 UTC
reproduced in LibO 3.6.0 master on Fedora 64 bit
Comment 4 A (Andy) 2013-05-06 20:50:36 UTC
the reported CPU issue is for me not reproducible with LO 4.0.2.2 (Win7 Home, 64bit), but I can't see the eps picture, I have only a red frame with textual picture data

Does this CPU issue still persist for you with the latest release of LO?
Comment 5 Jean-Baptiste Faure 2013-05-07 05:10:45 UTC
Yes the issue is still there under Linux (LO 4.0.4.0+ under Ubuntu 12.04 x86-64) because LO under Linux is able to show the picture but that needs some CPU to compute it.
I am pretty sure that the issue would be different with a picture in svg format instead of eps.

Best regards. JBF
Comment 6 QA Administrators 2015-03-04 02:18:33 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1.2 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
This NEW Message was generated on: 2015-03-03
Comment 7 Jean-Baptiste Faure 2015-03-04 11:40:33 UTC
Tested again with LibreOffice 4.4.2.0.0+ built at home under Ubuntu 14.10 x86-64
I do not experience Writer freeze anymore when it generates the preview from the Postscript code. The time needed to generate the preview is visible but does not block Writer.

I close this bug report as WorksForMe. Please, feel free to reopen if you disagree.

Note:  there is an enhancement request for adding native postscript interpreter in LibreOffice. See bug 67464.

Best regards. JBF
Comment 8 David Kremer 2015-03-04 20:08:12 UTC
Actually, it works pretty well for me.
This bug may be closed. In 3 years, libreoffice improved drastically.
Comment 9 David Kremer 2015-03-04 20:09:12 UTC
(In reply to David Kremer from comment #8)
> Actually, it works pretty well for me.
> This bug may be closed. In 3 years, libreoffice improved drastically.

I must add also that the svg format has been, so far, the best vectorial format to use with libreoffice. However with my last test, the eps format works just fine.

Regards.