Bug Hunting Session
Bug 37653 - Color fill merging for different header styles (only with the same colors).
Summary: Color fill merging for different header styles (only with the same colors).
Status: RESOLVED DUPLICATE of bug 106021
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: ODF-import
  Show dependency treegraph
 
Reported: 2011-05-26 23:10 UTC by Zuzukrukov
Modified: 2017-10-21 23:30 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of the bug. There is 4 header styles and 5 headers using this styles. First two lines - is a bug, another one - ok. (9.50 KB, application/vnd.oasis.opendocument.text)
2011-05-26 23:10 UTC, Zuzukrukov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zuzukrukov 2011-05-26 23:10:00 UTC
Created attachment 47208 [details]
Example of the bug. There is 4 header styles and 5 headers using this styles. First two lines - is a bug, another one - ok.

When you create color fill in style "header_1" and "header_2" (for example) with identical color fill, and add some vertical margins for one or both styles - the margins will fill the color too, but they shouldn't. If the color are different - there is no problem.
Comment 1 Björn Michaelsen 2011-12-23 12:06:49 UTC Comment hidden (obsolete)
Comment 2 Roman Eisele 2012-05-02 08:13:01 UTC
[REPRODUCIBLE] with LibreOffice 3.5.3.2 (Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80), German UI, on MacOS X 10.6.8.

Just to avoid misunderstandings: this bug report is talking about styles for headlines, not about page headers/footers (see attached sample file).

To explain the issue a bit lengthy (I did not understand the original description at the first glance):

There is a general behaviour in LibreOffice Writer that two paragraphs immediately following each other and having the same background color will get displayed like 'merged' to one rectangle with the same background color, even if there is some (vertical) spacing after the 1st and/or before the 2nd paragraph. For example, if you have two paragraphs with DIFFERENT backgrond color and some (vertical) spacing after the 1st and/or before the 2nd paragraph, they look like this:

+--------------------------------------------+
| First paragraph                            |
+--------------------------------------------+


+--------------------------------------------+
| Second paragraph                           |
+--------------------------------------------+

But the background color of both paragraphs is the same, they look like this, showing one single rectangle of background color:

+--------------------------------------------+
| First paragraph                            |
|                                            |
|                                            |
|                                            |
| Second paragraph                           |
+--------------------------------------------+

Whether this behaviour is right or wrong for ordinary paragraphs of ordinary text, might be disputed (this may be a feature or a bug).

But Zuzukrukov's report specifically talks about two headlines following each other, and here the current behaviour is really disturbing. The background color is handled like in ordinary paragraphs, i.e., when two headlines with the same background colors follow each other immediately, they get a single background color rectangle:

+--------------------------------------------+
| 1. Main headline                           |
|                                            |
|                                            |
|                                            |
| 1.1 Subhead                                |
+--------------------------------------------+

The same is shown by Zuzukrukov's sample file.

IMHO the current behaviour is irritating, especially for headlines; in my example, the user will probably not want to have the main headline (1.) and the subhead line (1.1.) to look similar to a single headline because of the common background rectangle.
Comment 3 Chris Tapp 2013-01-11 13:55:02 UTC
Is this issue being worked on at the moment?

It is currently affecting a project I am working on and I can't find a work round as I'm hoping to create a print-ready pdf which uses a single spot color.
Comment 4 Chris Tapp 2013-01-11 14:28:52 UTC
It may be work noting that I tried to use a single-pixel graphic image to solve the problem.

When set to 'Tile' I got the same behavior (i.e. color in the 'space before' region).

However, using the 'Area' option gives the desired behavior (i.e no color in the space). Stranger still, setting either of the heading graphics to 'Area' makes it work.
Comment 5 QA Administrators 2015-02-19 15:45:23 UTC Comment hidden (obsolete)
Comment 6 Chris Tapp 2015-02-19 16:45:38 UTC
Rechecked using 4.4.0.3 under OS X Yosemite.

Behaviour is as before (ignoring GUI changes for the settings).

Using Area / Fill / Bitmap (with a single pixel for the desired colour) and setting "Autofit" gives a work around.
Comment 7 QA Administrators 2016-02-21 08:37:42 UTC Comment hidden (obsolete)
Comment 8 QA Administrators 2017-03-06 15:59:18 UTC Comment hidden (obsolete)
Comment 9 Thomas Lendo 2017-10-21 23:30:16 UTC
Closing this bug as duplicate of the newer bug because there is detailed information from Regina Henschel about the cause and more test files.

*** This bug has been marked as a duplicate of bug 106021 ***