Download it now!
Bug 37703 - Pictures cannot be pasted into writer when copied from a web browser
Summary: Pictures cannot be pasted into writer when copied from a web browser
Status: VERIFIED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-28 14:55 UTC by Sam
Modified: 2014-06-27 21:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sam 2011-05-28 14:55:25 UTC
Copy text and images from a website using the Safari browser on Mac OS X.
Paste into Blank Writer document. 
The text is copied and pasted but images are not. 
The images should also be pasted. 
Testing with the Chrome browser copies and pastes images. 

The images appear to be copied successfully as pasting the same selection into Pages produces the images and text

LibreOffice 3.3.2 build 202 On Mac OS X 10.6.7
Comment 1 noname 2011-05-28 17:53:42 UTC
That might be a browser problem. I have the same problem. FF (windows) copies and pastes the text and images while opera only copies and pastes text.
Comment 2 Sam 2011-05-28 18:10:55 UTC
Microsoft's Word and Apple's Pages is able to extract the images the from Safari's clipboard. Have also reproduced the same results on another Mac. 

Safari Version 5.0.5 (6533.21.1) was used. 

Tested with Firefox and this is not a problem, so only with Safari. 

Is it possible the Safari (and Opera) stores images differently on the clipboard? Could LibreOffice not be extended to check for that and retrive the images as Microsoft Word is able get the images?
Comment 3 Björn Michaelsen 2011-12-23 12:04:05 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 4 Florian Reisinger 2012-08-14 14:02:49 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:03:44 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:08:19 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Florian Reisinger 2012-08-14 14:10:23 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 8 sasha.libreoffice 2012-09-06 11:56:51 UTC
reproduced in 3.3.4 and 3.6.1 copy-pasting Libreoffice.org from Konqueror on Fedora 64 bit. Biggest picture on right hand side not pasted.

Konqueror, Chrome, Chromium, Safary have the same engine Khtml/WebKit.
So, additional testing on Chrome, Chromium needed
Comment 9 Jorendc 2013-01-29 19:18:46 UTC
I also can confirm this problem that pictures aren't pasted in writer. I paste the same clipboard to 'Word for Mac 2011' and the pictures are pasted correctly.

Following [1] I mark this as 'major high'. We can't speak of 'data loss' because the data just isn't there at all. (and saving and reopening the document gives the same result).

Also I mark it as 3.3.0 beta2, following version of bug reporter.

Kind regards,
Joren
Comment 10 tommy27 2013-09-26 09:24:42 UTC
@Mac users
is issue still there with current 4.0.5 or 4.1.1 releases?
Comment 11 retired 2013-09-26 15:05:04 UTC
Hi tommy27, thanks for the ping.

This is still valid for LO 4.1.2.2 and latest master build on OS X 10.8.5.

Image pasted from Safari does not arrive in LO, but does arrive when e.g. pasted into Word 2010.
Comment 12 narayanaras 2014-06-27 11:00:16 UTC
Changed summary because this happens in FireFox in a Windows machine too.

BTW the 4.3.0.1 does NOT have this issue. (The issue was there till 4.2.4).
Comment 13 tommy27 2014-06-27 17:22:38 UTC
I confirm it works under Win7x64 using 4.3.0 RC1

status --> RESOLVED WORKSFORME
Comment 14 retired 2014-06-27 21:17:08 UTC
Verified. Thanks to the unknown commit fixing this!