Bug 37704 - FILEOPEN docx: drawing textboxes imported with wrong size & position
Summary: FILEOPEN docx: drawing textboxes imported with wrong size & position
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86 (IA32) All
: low normal
Assignee: Bryan Thoreson
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-05-28 21:25 UTC by Christopher M. Penalver
Modified: 2013-11-15 11:32 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
SPAserver230108.docx (44.88 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-05-28 21:25 UTC, Christopher M. Penalver
Details
docx file with bad textbox formatting (96.74 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2013-02-12 20:27 UTC, Bryan Thoreson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-05-28 21:25:16 UTC
Created attachment 47260 [details]
SPAserver230108.docx

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/185683

OOo bug may be found at:
http://qa.openoffice.org/issues/show_bug.cgi?id=93842

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/185683/+attachment/195539/+files/SPAserver230108.docx && lowriter -nologo SPAserver230108.docx

is that it looks as it does in Word 2003 ( https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/185683/+attachment/2145493/+files/Screenshot.png ).

4) What happens instead is the contents on the first page is completely gone. The document was made in Office 2007.
Comment 1 Björn Michaelsen 2011-12-23 12:01:54 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Christopher M. Penalver 2012-01-03 15:46:37 UTC
Reproducible in:
LOdev 3.5.0beta2 
Build ID: 8589e48-760cc4d-f39cf3d-1b2857e-60db978
Microsoft Windows Vista Business 6.0.6002 Service Pack 2 Build 6002
Comment 3 Rainer Bielefeld Retired 2012-05-03 22:15:07 UTC
@Christopher M. Penalver:
View in MS WORD VIEWER and LibO 3.6 Master are so different that it's not easy to find out that it's the same document ;-)

Concering what of the lots of problems is this Report?
Comment 4 Christopher M. Penalver 2012-05-04 03:15:18 UTC
Rainer Bielefeld, looks like we have dramatic improvement as the text boxes are visible, in the correct positions, and have the correct content.

RESOLVED WORKSFORME

lsb_release -rd
Description:	Ubuntu 12.04 LTS
Release:	12.04

 apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status
Comment 5 Bryan Thoreson 2013-02-12 20:27:38 UTC
Created attachment 74710 [details]
docx file with bad textbox formatting

I still see textbox formatting issues with docx files.
Comment 6 Bryan Thoreson 2013-02-12 20:28:38 UTC
I'm seeing formatting issues on Windows 8 64 bit, LibreOffice 4.0.0.3
Comment 7 Christopher M. Penalver 2013-02-17 13:42:13 UTC
Bryan Thoreson, thank you for your help. Please do not reopen this bug, as the issue you have is either a different problem, or a regression. Instead, please open a new report following http://wiki.documentfoundation.org/BugReport .

Thank you for your understanding.