Bug 37837 - VIEWING Writer vertically scrolling in .odt with eps becomes unresponsive for 10+ seconds
Summary: VIEWING Writer vertically scrolling in .odt with eps becomes unresponsive for...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: All Linux (All)
: low normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: bibisected, regression
: 68031 76945 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-01 14:57 UTC by Christopher M. Penalver
Modified: 2015-12-15 11:03 UTC (History)
9 users (show)

See Also:


Attachments
eps-example.odt (12.70 KB, application/vnd.oasis.opendocument.text)
2011-06-01 14:57 UTC, Christopher M. Penalver
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-06-01 14:57:42 UTC
Created attachment 47445 [details]
eps-example.odt

Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/513980

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/openoffice.org/+bug/513980/+attachment/2151023/+files/eps-example.odt && lowriter -nologo eps-example.odt

is one may scroll vertically through the document quickly and successfully.

4) What happens instead is it does not. It frequently becomes unresponsive for tens of seconds at a time.
Comment 1 Björn Michaelsen 2011-12-23 12:03:14 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 sasha.libreoffice 2012-01-06 01:02:48 UTC
reproduced on LibO 3.5.0 beta 1 on Fedora 64 bit
and on Windows just empty square instead of diagram
Comment 3 A (Andy) 2013-05-03 21:47:20 UTC
the scrolling problem is for me not reproducible with LO 4.0.2.2 (Win7 Home, 64bit)

But I can confirm as per Sasha's comment that on page two there is only an empty square.
Comment 4 A (Andy) 2013-05-03 21:49:49 UTC
Does this issue still persist for you with the latest release of LO?

If not, then I would propose to close this issue, but to open a new bug report regarding the red square on page two.
Comment 5 sasha.libreoffice 2013-05-04 07:07:04 UTC
reproduced in Version 4.0.2.2 on Fedora (RFR) 64 bit

Separate bug about problems on Windows:
Bug 47458 - [Task] EPS graphics not displayed properly
Comment 6 A (Andy) 2013-05-04 07:56:31 UTC
@Sasha: Can you also confirm this scrolling problem with Windows?  I can't confirm it on my Windows PC, the scrolling works fine as expected.
Comment 7 sasha.libreoffice 2013-05-06 05:49:26 UTC
in 4.0.2 on Windows XP 32bit only red frame with two lines of text instead of picture on second page. No slow down.
Comment 8 Christopher M. Penalver 2013-05-06 09:39:31 UTC
Problem noted in the Description https://bugs.freedesktop.org/show_bug.cgi?id=37837#c0 reproducible in:
Version 4.0.2.2 (Build ID: 400m0(Build:2))

lsb_release -rd
Description:	Ubuntu 13.04
Release:	13.04

apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:4.0.2-0ubuntu1
  Candidate: 1:4.0.2-0ubuntu1
  Version table:
 *** 1:4.0.2-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages
        100 /var/lib/dpkg/status
Comment 9 Björgvin Ragnarsson 2013-09-20 01:03:28 UTC
*** Bug 68031 has been marked as a duplicate of this bug. ***
Comment 10 Björgvin Ragnarsson 2013-10-02 21:00:06 UTC
I tracked a regression down to this commit:

"commit c0ce7ca4884f7f6d1016bd1dbcc22066cb4a7797
Author: Tomaž Vajngerl <quikee@gmail.com>
Date:   Sat Jul 7 13:07:03 2012 +0200

    Prescale image with Bitmap::Scale to improve quality.
    
    In OutputDevice, when sending the Bitmap to native renderer, use
    Bitmap::Scale operation to improve quality when doing sub-sampling.
    With this Bitmaps in certain Widgets will look a lot better.
    
    Cleanup and translate comments, and move sal_Bool to bool in outdev2.cxx"



This commit improves the quality of the rendering but also adds unnecessary rerendering of EPS figures when scrolling.
Comment 11 Jean-Sébastien Gosselin 2014-03-16 05:10:37 UTC
Using libreoffice-writer 1:4.2.1-0ubuntu1~saucy1 on Ubuntu 13.10 64 bit and I am experiencing this bug as well.

Would it be possible to have some details about the current status of this bug please?

I would be so glad to be able to work efficiently in Writer with a document containing eps. Currently, I either have to disable graphic display or use png. I think that having a poor rendering of eps in Writer would be 100 times better then poor vertical scrolling. I can see why some people may disagree with that though... I'm talking only for my particular situation.

For example, I find the way Scribus is handling eps quite wonderful honestly. eps are rendered as a low quality preview (quality can be user defined), allowing you to move things around really smoothly. It is possible to activate a Preview mode of the document that will improve the rendering of the eps, but make the document less responsive.
Comment 12 Björgvin Ragnarsson 2014-05-04 17:23:15 UTC
*** Bug 76945 has been marked as a duplicate of this bug. ***
Comment 13 V Stuart Foote 2015-09-11 08:23:58 UTC
@Björgvin, *

(In reply to Björgvin Ragnarsson from comment #10)
> I tracked a regression down to this commit:
> 
> "commit c0ce7ca4884f7f6d1016bd1dbcc22066cb4a7797
> Author: Tomaž Vajngerl <quikee@gmail.com>
> Date:   Sat Jul 7 13:07:03 2012 +0200
> 
>     Prescale image with Bitmap::Scale to improve quality.
>     
>     In OutputDevice, when sending the Bitmap to native renderer, use
>     Bitmap::Scale operation to improve quality when doing sub-sampling.
>     With this Bitmaps in certain Widgets will look a lot better.
>     
>     Cleanup and translate comments, and move sal_Bool to bool in outdev2.cxx"
> 
> 
> 
> This commit improves the quality of the rendering but also adds unnecessary
> rerendering of EPS figures when scrolling.

The outdev code was largely refactored starting Mar/Apr 2014 by Chris S. and has had a lot of continued work. With current 5.0.2.1 RC1 release I really don't see much lag on scrolling onto pages with EPS present.

Attachment 58882 [details] for example (a much more complex example of handling EPS Impress) moves about nicely. And when majority of those EPS are extracted and pasted into a Writer document--no issues with scrolling in Writer either.

Believe this can be Resolved WFM.  But please reopen if there is a reproducible test case with current release.

=-ref-=
http://opengrok.libreoffice.org/history/core/include/vcl/outdev.hxx
Comment 14 Robinson Tryon (qubit) 2015-12-15 11:03:29 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]