Bug 37881 - LibreOffice 3.4.0, global menu, unity integration, unity 2d
Summary: LibreOffice 3.4.0, global menu, unity integration, unity 2d
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 50017 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-03 08:29 UTC by Guillaume Majeau-Bettez
Modified: 2013-01-08 12:21 UTC (History)
4 users (show)

See Also:


Attachments
lo-menubar package reworked into extension (35.52 KB, application/vnd.openofficeorg.extension)
2011-06-03 17:03 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Guillaume Majeau-Bettez 2011-06-03 08:29:03 UTC
In the LibO 3.4.0 (final) release notes, one interesting feature is the native integration with the Ubuntu Unity global menu. 

I installed the debs from LibO_3.4.0_Linux_x86_install-deb_en-US.tar.gz, including the only desktop-integration file (libreoffice3.4-debian-menus_3.4-12_all.deb). Still the integration with global menu does not seem to occur.  I switched from Unity 2d to "normal" unity, switched from Compiz to metacity window managers, temporarily uninstalled desktop-integration, even restarted...to no avail. Nothing helped. Any tips? 

I run Ubuntu 11.04, on a 32bit machine.
Comment 1 Luke 2011-06-03 17:01:18 UTC
It appears that this feature is being developed as an extension. On Ubuntu 11.04, there is a package "lo-menubar", but this depends on libreoffice 3.3, and thus you can't install it with libreoffice3.4. The development site is at https://launchpad.net/lo-menubar.
I downloaded the Ubuntu package and extracted it. I then put the main bits together in an extension (attached). It works for me with "LibreOffice 3.4.0 
OOO340m1 (Build:12)", Ubuntu 11.04 64bit.
Comment 2 Luke 2011-06-03 17:03:00 UTC
Created attachment 47502 [details]
lo-menubar package reworked into extension

Install by opening libreoffice and going Tools->Extensions->Add.
Comment 3 Rainer Bielefeld Retired 2011-06-10 02:57:34 UTC
RC2 is bit by bit identical with release version, so separate items in the version picker are useless. Changes have been discussed with Michael Meeks.
Comment 4 renshamburger 2011-07-11 02:41:15 UTC
(In reply to comment #0)
> In the LibO 3.4.0 (final) release notes, one interesting feature is the native
> integration with the Ubuntu Unity global menu. 
> 
> I installed the debs from LibO_3.4.0_Linux_x86_install-deb_en-US.tar.gz,
> including the only desktop-integration file
> (libreoffice3.4-debian-menus_3.4-12_all.deb). Still the integration with global
> menu does not seem to occur.  I switched from Unity 2d to "normal" unity,
> switched from Compiz to metacity window managers, temporarily uninstalled
> desktop-integration, even restarted...to no avail. Nothing helped. Any tips? 
> 
> I run Ubuntu 11.04, on a 32bit machine.

I found problems with the 32 bit libreoffice too at http://askubuntu.com/questions/51420/application-menu-support-for-libreoffice-3-4-1 is an work arround
Comment 5 Björn Michaelsen 2011-12-23 12:05:38 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 6 Michael Hall 2012-02-15 12:19:48 UTC
I can confirm that this still persists in Ubuntu 12.04 using version 3.5.0beta2
Comment 7 Adolfo Jayme 2012-07-22 01:51:55 UTC
*** Bug 50017 has been marked as a duplicate of this bug. ***
Comment 8 Adolfo Jayme 2013-01-08 12:21:24 UTC
This should be adressed in LibreOffice 3.6 (included in Quantal).