Bug 37886 - FILEOPEN TABLES RTF cell content is shifted upward into other cells with table cells being deleted
Summary: FILEOPEN TABLES RTF cell content is shifted upward into other cells with tabl...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 RC1
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: regression
: 40246 (view as bug list)
Depends on:
Blocks: 38025
  Show dependency treegraph
 
Reported: 2011-06-03 09:31 UTC by Christopher M. Penalver
Modified: 2013-11-15 11:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
example.rtf.bz2 (32.48 KB, application/x-bzip)
2011-06-03 09:32 UTC, Christopher M. Penalver
Details
Screenshots, See Comment 4 (133.70 KB, application/pdf)
2011-08-25 01:42 UTC, Rainer Bielefeld Retired
Details
Single page testcase instead of the insanely large original one. (33.27 KB, application/rtf)
2011-08-28 13:20 UTC, Miklos Vajna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2011-06-03 09:31:45 UTC
Downstream bug may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/792412

1) lsb_release -rd
Description: Ubuntu 11.04
Release: 11.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.3.2-1ubuntu5
  Candidate: 1:3.3.2-1ubuntu5
  Version table:
 *** 1:3.3.2-1ubuntu5 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.3.2-1ubuntu4 0
        500 http://us.archive.ubuntu.com/ubuntu/ natty/main i386 Packages

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/792412/+attachment/2153573/+files/example.rtf && lowriter -nologo example.rtf

is the cell content placement is preserved.

4) What happens instead is the cell contents are shifted upward into other cells and table cells are deleted.
Comment 1 Christopher M. Penalver 2011-06-03 09:32:51 UTC
Created attachment 47486 [details]
example.rtf.bz2
Comment 2 clio 2011-06-07 11:03:07 UTC
Regression against LibO 3.3.2
Comment 3 Rainer Bielefeld Retired 2011-08-25 01:19:12 UTC
*** Bug 40246 has been marked as a duplicate of this bug. ***
Comment 4 Rainer Bielefeld Retired 2011-08-25 01:37:16 UTC
[Reproducible] with reporter's sample document and "LibreOffice 3.4.3 RC1 - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:301)]", for details see attached screenshots!

Sample document looks fine with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]" 

Please also see "Bug 40246 - FILEOPEN RTF: All rows or columns of table shown as one" and "Bug 39337 - RTF document with table not displayed correctly", what might have the same roots (or even be DUPs).

@Miklós:
Is your RTF initiative still active?
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 Rainer Bielefeld Retired 2011-08-25 01:41:45 UTC
The VERSION picker seems to be wrong (LibO 3.3.2), report (and my results) say that there everything worked normal. So Version - > mine.
Comment 6 Rainer Bielefeld Retired 2011-08-25 01:42:37 UTC
Created attachment 50558 [details]
Screenshots, See Comment 4
Comment 7 Miklos Vajna 2011-08-28 13:20:59 UTC
Created attachment 50639 [details]
Single page testcase instead of the insanely large original one.
Comment 8 Miklos Vajna 2011-08-28 13:23:47 UTC
Rainer,

In master the table layout is fine (just like in 3.3), but it's still buggy, compared to Word: in Writer the first cell (not counting the header) is "1.\t31.", while in Word it's just "1.\t".

I'll try to see if I can fix that, I would not close this bug before.

Thanks.
Comment 9 Miklos Vajna 2011-08-29 14:58:56 UTC
It turns the issue I was talking about is a layout one, if you save the doc using Word as .doc, then the same problem is already there, let's forget about it for now.

So this bug should be fixed with

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13c00ce322e78eb4e0f50ab84ded19cd6aae1ded

(Please don't request a backport, the new filter won't be backported to -3-4.)

Thanks.
Comment 10 Björn Michaelsen 2011-12-23 13:26:25 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.
Comment 11 Jean-Baptiste Faure 2012-03-19 13:20:29 UTC
Works as expected in LO 3.5.1. Closing. Thank you.