Bug 37993 - FILESAVE: ODF formula export: errors incorrectly saved
Summary: FILESAVE: ODF formula export: errors incorrectly saved
Status: CLOSED DUPLICATE of bug 51810
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: high major
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: odf odf_validation
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-06 07:33 UTC by Andreas J Guelzow
Modified: 2013-06-24 15:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample file (8.00 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-06-06 07:33 UTC, Andreas J Guelzow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas J Guelzow 2011-06-06 07:33:05 UTC
Created attachment 47604 [details]
sample file
Comment 1 Andreas J Guelzow 2011-06-06 07:37:42 UTC
In the attached file we have:
<table:table-cell table:formula="of:=1/0" office:value-type="float" office:value="0"><text:p>#DIV/0!</text:p></table:table-cell>

This conflicts with the ODF1.2 specification that specifies in Part 2 4.6 Error:
"In an OpenDocument document, if an error value is the result of a cell computation it shall be stored as if it was a string. That is, the office:value-type of an error value is string; if the computed value is stored, it is stored in the attribute office:string-value."

So the office:value-type in this case must be "string", not "float". This file currently incorrectly claims that the result of "of:=1/0" is 0!
Comment 2 Andras Timar 2011-06-07 00:01:15 UTC
Thorsten, can you please look into this?
Comment 3 Michael Stahl 2012-01-30 09:06:18 UTC
Eike: OpenFormula looks like your playground...
Comment 4 Eike Rathke 2012-01-30 10:59:10 UTC
Sounds familiar..
Comment 5 ign_christian 2013-06-24 09:10:22 UTC
With LO 4.0.4.2 (Win7 32bit), that file shows result #DIV/0!
Perhaps it's been fixed?
Comment 6 Eike Rathke 2013-06-24 11:37:41 UTC
It's not about what is displayed but how it is stored in the .ods file.

@moggi:
You wanted to tackle that after the cached values / inherited number formats, if I'm not mistaken?
Comment 7 Markus Mohrhard 2013-06-24 13:45:18 UTC
This should be fixed in 4.1 and master with my error value export. At least I thought so.

I'll check it but I closed my bug report for it.
Comment 8 Markus Mohrhard 2013-06-24 13:49:23 UTC

*** This bug has been marked as a duplicate of bug 51810 ***
Comment 9 Eike Rathke 2013-06-24 15:27:08 UTC
Ah yes, my bad, I only checked 4.0.4; it's already in 4.1