Bug 38003 - Calc doesn't print the content of a cell until you go out this cell
Summary: Calc doesn't print the content of a cell until you go out this cell
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 125932 140093 (view as bug list)
Depends on:
Blocks: Calc-Cells
  Show dependency treegraph
 
Reported: 2011-06-06 12:05 UTC by r.aviolat
Modified: 2021-09-14 14:06 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description r.aviolat 2011-06-06 12:05:48 UTC
I reported this bug two years ago to the openoffice reporting tool but had no news. Now I'm a LibreOffice user so I report it here too.

ISSUE:
1. Create a new spreadsheet
2. type something in a cell
3. Don't go out of this cell
4. Make a "Page Preview" every things seems fine
4. Try to print the document 
5. The content of the cell isn't printed

WORKAROUND:
1. Create a new spreadsheet
2. type something in a cell
3. Go out of this cell
4. Print the document 
5. The content of the cell is now printed

The problem also appears if you export into PDF instead for printing. 

It's not a big deal but it's quite annoying, our employees often complains that
OOO doesn't always print the whole content of their documents.

Thanks, Romain
Comment 1 Björn Michaelsen 2011-12-23 12:28:45 UTC Comment hidden (obsolete)
Comment 2 Florian Reisinger 2012-08-14 14:03:59 UTC Comment hidden (obsolete)
Comment 3 Florian Reisinger 2012-08-14 14:04:53 UTC Comment hidden (obsolete)
Comment 4 Florian Reisinger 2012-08-14 14:09:21 UTC Comment hidden (obsolete)
Comment 5 Florian Reisinger 2012-08-14 14:11:21 UTC Comment hidden (obsolete)
Comment 6 r.aviolat 2012-08-14 14:19:32 UTC
Hi Florian,

I confirm that the problem still exist in the 3.5.2 version
Comment 7 Roman Eisele 2012-09-03 13:28:39 UTC
(Not a problem with BASIC (the macro language), but a basic Calc problem, therefore adjusted component.)
Comment 8 Joel Madero 2014-11-04 03:41:52 UTC Comment hidden (obsolete)
Comment 9 Buovjaga 2014-11-16 09:25:23 UTC
I can't reproduce this.
Please test with latest version and report here. Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Win 7 64-bit Version: 4.4.0.0.alpha2+
Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08
Comment 10 r.aviolat 2014-11-16 10:04:18 UTC
Version: 4.2.7.2(In reply to Beluga from comment #9)
> I can't reproduce this.
> Please test with latest version and report here. Change back to UNCONFIRMED,
> if the problem persists. Change to RESOLVED WORKSFORME, if the problem went
> away.
> 
> Win 7 64-bit Version: 4.4.0.0.alpha2+
> Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
> TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08

Beluga,

I tried with the version packages into latest Linux Mint distribution:

Version: 4.2.7.2
Build ID: 420m0(Build:2)

And the problem persist, I'll try to obtain the latest version.
Comment 11 Anders Jonsson 2015-06-02 15:32:52 UTC
(In reply to Beluga from comment #9)
> I can't reproduce this.
> Please test with latest version and report here. Change back to UNCONFIRMED,
> if the problem persists. Change to RESOLVED WORKSFORME, if the problem went
> away.
> 
> Win 7 64-bit Version: 4.4.0.0.alpha2+
> Build ID: b021b5983c62e266b82d9f0c5c6d8d8900553827
> TinderBox: Win-x86@39, Branch:master, Time: 2014-11-12_01:10:08

Reproducible for me in Calc from Debian testing.
Version: 4.4.3.2
Build ID: 40m0(Build:2)


While I can't reproduce with the steps written in the original post, I can reproduce the issue with this shorter chain of events:

1. Create a new spreadsheet
2. type something in a cell
3. Don't go out of this cell
4. Press ctrl+P to print
5. The content of the cell isn't printed


If I either save the document, call "Page preview" with ctrl+shift+O or select another cell before I print, the changes are printed without problem.

(The bug can also be tested without printing, as ctrl+P also shows a print preview where changes to the affected cell aren't seen.)
Comment 12 Buovjaga 2015-06-02 15:39:38 UTC
Thanks, Anders. I'll set to NEW in that case.
Comment 13 QA Administrators 2016-09-20 09:45:52 UTC Comment hidden (obsolete)
Comment 14 Anders Jonsson 2016-09-20 12:42:25 UTC
Can confirm that it the bug is still present without changes in LO 5.2.1 in Debian testing.

Version: LibreOffice 5.2.1.2 20m0(Build:2)

Also tested with LO 3.3 where the bug also was present, so setting version as "inherited from OOo".
Comment 15 QA Administrators 2018-06-05 02:39:08 UTC Comment hidden (obsolete)
Comment 16 Anders Jonsson 2018-06-05 09:35:56 UTC
Can confirm that it the bug is still present in LO 6.0.5 in Debian testing.

Version: 6.0.5.1
Build ID: 1:6.0.5~rc1-2
Comment 17 QA Administrators 2019-06-06 02:54:11 UTC Comment hidden (obsolete)
Comment 18 Timur 2019-06-06 08:36:38 UTC
Repro 6.4+.
Comment 19 cpohle 2021-02-02 21:14:49 UTC
*** Bug 140093 has been marked as a duplicate of this bug. ***
Comment 20 cpohle 2021-02-02 21:18:13 UTC
Having a hardcopy showing content different from what the user is seeing on screen should not be accepted for about 10 years. Please see my comment to bug 140093#c2
Comment 21 Timur 2021-09-14 14:06:25 UTC
*** Bug 125932 has been marked as a duplicate of this bug. ***