Bug 38038 - in Gnome: Text color in menubar unreadable when clicked
Summary: in Gnome: Text color in menubar unreadable when clicked
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-06-07 07:24 UTC by jonathan.denil
Modified: 2016-05-01 13:07 UTC (History)
5 users (show)

See Also:


Attachments
Screenshot (106.49 KB, image/png)
2011-06-07 12:32 UTC, jonathan.denil
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jonathan.denil 2011-06-07 07:24:28 UTC
With LibreOffice 3.4, the text color of the menubar becomes unreadable wgen clicked. For example, if you open Writer and click on 'File' in the menubar, the text becomes white on a light grey background, which makes it unreadable. This worked fine with LibreOffice 3.3.

System information: 
Arch Linux x64
Gnome 3 + Gnome-Shell
Aldabra GTK theme (http://gnome-look.org/content/show.php/Aldabra?content=142247)
LibreOffice 3.4

This bug report is filed because it seems like a regression from LO 3.3 --> 3.4, see the official thread of the Aldabra GTK theme: http://ubuntuforums.org/showpost.php?p=10908827&postcount=62
Comment 1 jonathan.denil 2011-06-07 12:32:05 UTC
Created attachment 47679 [details]
Screenshot

See the 'Edit' menu entry (at the mouse pointer), that has become unreadable.
Comment 2 jonathan.denil 2011-10-19 08:12:31 UTC
This bug isn't picked up yet and at least deserves some attention after a couple of months. A lot of users are having the same issue with other themes, for example Zukitwo GTK2/GTK3 theme (find it on Deviantart). I talked to the author of the theme and this is his explanation: 

==> Libreoffice doesn't pull the correct color from the gtkrc file. You should report a bug to the libreoffice-gtk devs. The menubar seems to pull the color from GtkMenu. It should pull the color from GtkMenuBar and the sub-class GtkMenuItem.
Comment 3 Conner 2011-11-19 15:59:35 UTC
Confirmed on Libreoffice 3.4.4, Gnome 3.2.1 and GTK 2.24.8. Using Aldabra theme.
Comment 4 Björn Michaelsen 2011-12-23 12:21:16 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 5 Adolfo Jayme 2012-01-24 18:30:34 UTC
This bug still persists, setting to New.
Comment 6 Saurav Sengupta 2012-04-09 04:08:44 UTC
This bug is still present in LibreOffice 3.5.2. Is there any update on this?
Comment 7 d1g1t 2012-05-28 07:53:28 UTC
To fix this just change:

        bg[SELECTED] = @selected_bg_color -> bg[SELECTED] = @base_color  

in GTKRC style "dark" to look like this:


style "dark"
{
        bg[NORMAL]   = @bg_color
        bg[PRELIGHT] = shade (0.96, @bg_color)
        bg[SELECTED] = @base_color       
        bg[ACTIVE]   = shade (0.96, @bg_color)
        bg[INSENSITIVE]   = @bg_color
}

make sure that you have some bright color in @base_color or use another variable or direct value #fff

bg[SELECTED] = @selected_bg_color is just to dark so it fall backs to light text.

At least if fixed the issue in theme that i use: Orion :)
Comment 8 d1g1t 2012-05-28 07:55:34 UTC
It is also possible that it can be fixed by modifying background color in more specific sections then parrent "dark" havent tried :)
Comment 9 sophie 2014-12-31 13:22:26 UTC
Hi Jonathan, did you tried the workaround in GTKRC and does it solve the issue?
Sophie
Comment 10 QA Administrators 2016-01-17 20:02:17 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 11 Caolán McNamara 2016-03-11 16:18:53 UTC
In master with the preferred gtk3 direction the menubar is now a native menubar so all theming issues there are moot for gtk3 + 5.2
Comment 12 Jean-Baptiste Faure 2016-05-01 13:07:38 UTC
Keyword regression added from bug description (worked in version 3.3).

Best regards. JBF