Bug 38045 - FILESAVE: Missing function prefix
Summary: FILESAVE: Missing function prefix
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: (target:3.6.1)
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-07 11:45 UTC by Andreas J Guelzow
Modified: 2012-08-31 10:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample file (8.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2011-06-07 11:45 UTC, Andreas J Guelzow
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas J Guelzow 2011-06-07 11:45:02 UTC
Created attachment 47676 [details]
sample file

The attached file was generated by LibreOffice 3.3.2 and includes:

<table:table-cell table:formula="of:=EASTERSUNDAY(1900)" office:value-type="date" office:date-value="1900-04-15"><text:p>1900-04-15</text:p></table:table-cell>

The table:formula attribute value of "of:=EASTERSUNDAY(1900)" claims to be an OpenFormula expression but according to ODF 1.2 Part 2:
---------------------------------------------------------
5.7 Nonstandard Function Names
When writing a document using function(s) not defined in this specification, an evaluator shall include a prefix in such function names to identify the original definer of the function's semantics. When the origin of a function cannot be determined, producers may omit a prefix. 
---------------------------------------------------------

Since EASTERSUNDAY as used here is a LibreOffice/OpenOffice function it should carry a prefix.
Comment 1 Björn Michaelsen 2011-12-23 12:27:30 UTC
[This is an automated message.]
This bug was filed before the changes to Bugzilla on 2011-10-16. Thus it
started right out as NEW without ever being explicitly confirmed. The bug is
changed to state NEEDINFO for this reason. To move this bug from NEEDINFO back
to NEW please check if the bug still persists with the 3.5.0 beta1 or beta2 prereleases.
Details on how to test the 3.5.0 beta1 can be found at:
http://wiki.documentfoundation.org/QA/BugHunting_Session_3.5.0.-1

more detail on this bulk operation: http://nabble.documentfoundation.org/RFC-Operation-Spamzilla-tp3607474p3607474.html
Comment 2 Andreas J Guelzow 2011-12-23 13:04:35 UTC
I will not waste my time with checking whether this is still true in some recent unreleased version. I filed this report as a service to the LibreOffice user community. I am of course _not_ using LO myself. So if you don't care about these bugs, feel free to close this report.
Comment 3 Florian Reisinger 2012-08-14 14:02:57 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 4 Florian Reisinger 2012-08-14 14:03:52 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 5 Florian Reisinger 2012-08-14 14:08:26 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 6 Florian Reisinger 2012-08-14 14:10:29 UTC
Dear bug submitter!

Due to the fact, that there are a lot of NEEDINFO bugs with no answer within the last six months, we close all of these bugs.

To keep this message short, more infos are available @ https://wiki.documentfoundation.org/QA/NeedinfoClosure#Statement

Thanks for understanding and hopefully updating your bug, so that everything is prepared for developers to fix your problem.

Yours!

Florian
Comment 7 Michael Meeks 2012-08-14 19:01:34 UTC
Running 3.6.0 / master I get:

     <table:table-cell table:formula="of:=ORG.OPENOFFICE.EASTERSUNDAY(1900)" office:value-type="date" office:date-value="1900-04-15">

Which I assume is correct.
Comment 8 Rainer Bielefeld Retired 2012-08-17 04:53:29 UTC
no fix known