Bug 38143 - No circumflex accents when using a French keyboard on kubuntu
Summary: No circumflex accents when using a French keyboard on kubuntu
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 45715 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-06-10 02:31 UTC by Tom Vercauteren
Modified: 2012-06-09 13:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Vercauteren 2011-06-10 02:31:26 UTC
Hi,

I have moved to kubuntu 11.04 on amd64 and thus switched from openoffice to libreoffice 3.3.2.

I am using a French keyboard on a system configured to use English language by default. Outside of LibreOffice, all my accents works fine, e.g. é è ê ë.

In LibreOffice, satndard one-key accents (e.g. é è) work fine but the "composed" circumflex accents typed for example as ^+e (e.g. ê ë) don't. The result is simply the letter without accent.

I tried to circumvent the problem by using the more standard way of composing (compose-key+^+e) but this does not work on my system (in or outside of LibreOffice).

Right now I have to rely on the spell checker picking up the right work or copy and paste. Any fix or better workaround would be appreciated.

If this is of any help, I also tried installing openoffice.org-l10n-fr but this does not change the problem.

From a web search about my problem, I was not able to find any useful information.

Best regards,
Tom

> uname -a
Linux comp 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

> locale
LANG=en_US.UTF-8
LANGUAGE=
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"                                                                                                                             
LC_IDENTIFICATION="en_US.UTF-8"                                                                                                                          
LC_ALL=

> about libreoffice
LibreOffice 3.3.2 
OOO330m19 (Build:202)
tag libreoffice-3.3.2.2, Ubuntu package 1:3.3.2-1ubuntu5
Comment 1 Tom Vercauteren 2011-06-10 02:35:24 UTC
Hi again,

I think I was a little fast in filing this bug. It is not restricted to LibreOffice but also applies to emacs.

Most other apps work just fine though (not only the QT based), e.g.:
- gedit
- google chrome
- firefox
- kword

Tom
Comment 2 Tom Vercauteren 2011-06-10 06:03:06 UTC
I'll close this bug. It seems like the problem lies with ibus + XIM software. Not sure what this exactly means but the following bug report seems to match my case:
http://code.google.com/p/ibus/issues/detail?id=526

Changing the input method to default-xim, logging out and back in seems to fix my problem:
im-switch -s default-xim

See http://ubuntuforums.org/showthread.php?p=10894791
Comment 3 Julien Nabet 2012-06-09 13:34:47 UTC
*** Bug 45715 has been marked as a duplicate of this bug. ***