Bug 38324 - EXTENSION CT2N does not work
Summary: EXTENSION CT2N does not work
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.0 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL: http://extensions.services.openoffice...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-06-14 22:10 UTC by Rainer Bielefeld Retired
Modified: 2011-09-28 07:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-06-14 22:10:06 UTC
User JohnT reported that this extension does not work as expected, I hope he will contribute a bug description here.
Comment 1 Yifan Jiang 2011-06-14 22:20:38 UTC
Platform: SLED 11 sp1 i586
build info: Libreoffice 3.4 release

The basic function w/ CT2N 1.4.0 looks working for me.
Comment 2 Rainer Bielefeld Retired 2011-06-18 13:31:57 UTC
Bug mentionend in original report was 
"Bug 33962 - Add CT2N Extension"
Comment 3 Alex Thurgood 2011-09-28 00:36:13 UTC
Confirming on Mac OSX with :

LibO-dev Master LibO-dev 3.5.0 
Build ID: 6058133-1b94742-3dca5fd-7252360

NeoOffice 3.2 patch 5
NeoOffice 3.1.2 patch 8
OpenOffice.org 3.2.1


Tested with following strings :
two thousand and fifty-five
three hundred point ten

also tested with French locale text number strings.

entered in cells A1 and A2 respectively. Selected the cells, clicked on the extension button in tool bar, also tried via addons menu entry.

The message box at the bottom of the convert dialog returns "Nothing to change".
Perhaps I have misunderstood how it is to be used ?

Also tried without the 'and' and 'point' - same result, i.e. non-functional. Formatted the strings explicitly as text with language as US or UK, same result, non-functional.


The problem appears to be general with respect to the Mac platform. This would appear to be the developer's problem, not ours, since it wouldn't be the first time that an extension has been OS specific. FWIW, I am uncertain as to whether I am using this extension correctly.


Alex
Comment 4 JohnT 2011-09-28 07:19:46 UTC
My apologies.Apparently the extension C2TN only converts numbers shown as text.
eg '1236 is text as it is prefixed with an apostrophe.
I don't think it was ever meant to convert One thousand two hundred and thirty six to a number entry.

Many thanks,  Tink.